summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-09 11:15:16 +0300
committerCaleb Maclennan2023-03-09 11:15:16 +0300
commitd8c93ee5b0b07e0001bd6e437408f86d6ab6864c (patch)
tree9fcc80bbe1a2b6545baa0932f26bddcf802a2482
parent68c39ec1ee9e8859b06542be9286c32bfc467729 (diff)
downloadaur-d8c93ee5b0b07e0001bd6e437408f86d6ab6864c.tar.gz
upgpkg: mattermost-plugin-focalboard 7.9.0-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 928ec5e066f2..bc232847b928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = mattermost-plugin-focalboard
pkgdesc = an open source, self-hosted alternative to Trello, Notion, and Asana
pkgver = 7.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.focalboard.com
arch = x86_64
- depends = mattermost>=7.2.0
+ license = MIT
+ makedepends = jq
options = !strip
- source = mattermost-plugin-focalboard-7.9.0.tgz::https://github.com/mattermost/focalboard/releases/download/v7.9.0/mattermost-plugin-focalboard.tar.gz
+ source = mattermost-plugin-focalboard-7.9.0.tar.gz::https://github.com/mattermost/focalboard/releases/download/v7.9.0/mattermost-plugin-focalboard.tar.gz
sha256sums = a215c5ba27c1bae82bf0fa385958b55f7e84c5d2aeed330cdfbbb3f11b3f3284
pkgname = mattermost-plugin-focalboard
diff --git a/PKGBUILD b/PKGBUILD
index 8552d9d26e1c..38343d427d06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,40 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Note the intention of this package is to bulid from source, but I haven't
+# gotten it to work yet. Contributions welcome! Temporarily it is installing
+# the upstream generated binary version.
+
_plugin=focalboard
pkgname=mattermost-plugin-$_plugin
pkgver=7.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='an open source, self-hosted alternative to Trello, Notion, and Asana'
arch=(x86_64)
url=https://www.focalboard.com
-_url="https://github.com/${pkgname%%-*}/${pkgname##*-}"
-license=()
-# jq -r .min_server_version mattermost-plugin/plugin.json
-depends=('mattermost>=7.2.0')
+_url="https://github.com/${pkgname%%-*}/$_plugin"
+license=(MIT)
+makedepends=(jq)
options=(!strip)
_archive="$pkgname-$pkgver"
-source=("$_archive.tgz::$_url/releases/download/v$pkgver/$pkgname.tar.gz")
+source=("$_archive.tar.gz::$_url/releases/download/v$pkgver/$pkgname.tar.gz")
sha256sums=('a215c5ba27c1bae82bf0fa385958b55f7e84c5d2aeed330cdfbbb3f11b3f3284')
-# Note the intention of this package is to bulid from source, but I haven't
-# gotten it to work yet. Contributions welcome! Temporarily it is installing
-# the upstream generated binary version.
+# BEGIN boilerplate mattermost plugin version clamping, see also other packages in group
+# 1. Call respective function helper in package() *after* cd'ing to the source directory
+# 2. Add makedepends+=(jq)
+_get_supported_ranges() {
+ _plugin_min_mattermost="$(< plugin.json jq -r '.min_server_version')"
+}
+_mattermost_plugin_package() {
+ _get_supported_ranges
+ depends+=("mattermost>=${_plugin_min_mattermost:-0}")
+}
+# END boilerplate mattermost plugin version clamping
package() {
local _plugins="$pkgdir/var/lib/mattermost/plugins"
install -dm0755 "$_plugins"
cp -r "$_plugin" "$_plugins"
+ cd "$_plugin"
+ _mattermost_plugin_package
}