summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-02-19 13:43:44 +0300
committerCaleb Maclennan2022-02-19 13:43:44 +0300
commit8b389458b90d4e3ef4186fff2ed5489840e72a72 (patch)
tree404ac4fa8fbb1e49f806eea65f837703d6b2c670
downloadaur-8b389458b90d4e3ef4186fff2ed5489840e72a72.tar.gz
Initial upload: mattermost-plugin-gitlab 1.4.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6e86abcb983
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mattermost-plugin-gitlab
+ pkgdesc = a GitLab plugin for Mattermost
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://mattermost.gitbook.io/plugin-gitlab
+ arch = x86_64
+ depends = mattermost
+ options = !strip
+ source = https://github.com/mattermost/mattermost-plugin-gitlab/releases/download/v1.4.0/com.github.manland.mattermost-plugin-gitlab-1.4.0.tar.gz
+ sha256sums = f097b1b978602e32fb6dc1ccd4c928b0fd9c7e7639dfddc17b36bcb945bc0c38
+
+pkgname = mattermost-plugin-gitlab
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b2db6c7e1a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_plugin=gitlab
+pkgname=mattermost-plugin-$_plugin
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='a GitLab plugin for Mattermost'
+arch=(x86_64)
+url=https://mattermost.gitbook.io/plugin-gitlab
+_url="https://github.com/mattermost/$pkgname"
+license=()
+depends=(mattermost)
+options=(!strip)
+_archive="com.github.manland.$pkgname"
+source=("$_url/releases/download/v$pkgver/$_archive-$pkgver.tar.gz")
+sha256sums=('f097b1b978602e32fb6dc1ccd4c928b0fd9c7e7639dfddc17b36bcb945bc0c38')
+
+# Note the intention of this package is to bulid from source, but I haven't
+# gotten it to work yet. Contributions welcome! Temporarily it is installing
+# the upstream generated binary version.
+
+package() {
+ ls -al
+ local _plugins="$pkgdir/var/lib/mattermost/plugins"
+ install -dm0755 "$_plugins"
+ cp -r "$_archive" "$_plugins"
+}