summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-01-27 16:25:12 +0100
committerMassimiliano Torromeo2016-01-27 16:25:21 +0100
commit1764d17fe1810a1712bf1b6346e7ee933eeb688d (patch)
treedd0a65329b304b1cb3df10c309c2c247630197e7
downloadaur-1764d17fe1810a1712bf1b6346e7ee933eeb688d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD25
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30bf5dbd03b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jan 27 15:24:28 UTC 2016
+pkgbase = mattersend
+ pkgdesc = CLI tool to send messages to the Incoming webhook of mattermost
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/mtorromeo/mattersend
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-setproctitle
+ source = http://pypi.python.org/packages/source/m/mattersend/mattersend-1.0.tar.gz
+ sha256sums = 28a0b1f0a8936809e2b6ef34ac69d0c5bfcba5d26f3c1f857016ed95a435596b
+
+pkgname = mattersend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37e53bd62421
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=mattersend
+pkgver=1.0
+pkgrel=1
+pkgdesc="CLI tool to send messages to the Incoming webhook of mattermost"
+arch=(any)
+url="https://github.com/mtorromeo/mattersend"
+license=('BSD')
+depends=(python-requests python-setproctitle)
+makedepends=(python-setuptools)
+source=(http://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha256sums=('28a0b1f0a8936809e2b6ef34ac69d0c5bfcba5d26f3c1f857016ed95a435596b')