summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWachid Adi Nugroho2023-06-24 23:40:02 +0700
committerWachid Adi Nugroho2023-06-24 23:40:02 +0700
commitd0008e599fa70663f5fd25c9de33b756871d9564 (patch)
tree253ef6c6eb699ce99f18b6655e234d919a5e35f5
parentb430ee665d924aaddbb060fedb21b6545b715194 (diff)
downloadaur-d0008e599fa70663f5fd25c9de33b756871d9564.tar.gz
Update depends list, fix licenses and bump version to 0.5.0.r0.g822eb2d-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d49028ede74..831c8aae3763 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = maui-agenda-git
pkgdesc = Calendar application built with MauiKit
- pkgver = 0.1.1.r0.gfb2ef22
+ pkgver = 0.5.0.r0.g822eb2d
pkgrel = 1
url = https://invent.kde.org/maui/agenda
arch = x86_64
@@ -10,17 +10,14 @@ pkgbase = maui-agenda-git
arch = armv7h
arch = aarch64
groups = maui
- license = GPL3
+ license = LGPL3
makedepends = git
makedepends = extra-cmake-modules
- depends = akonadi-contacts
- depends = calendarsupport
- depends = eventviews
- depends = kconfig
+ depends = akonadi
depends = kcoreaddons
depends = ki18n
- depends = libakonadi
- depends = mauikit-git
+ depends = mauikit-calendar
+ depends = mauikit
depends = qt5-base
depends = qt5-declarative
provides = maui-agenda
diff --git a/PKGBUILD b/PKGBUILD
index adc4768d287b..74f4f41df03e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,17 @@
_pkgname=maui-agenda
pkgname=$_pkgname-git
-pkgver=0.1.1.r0.gfb2ef22
+pkgver=0.5.0.r0.g822eb2d
pkgrel=1
pkgdesc='Calendar application built with MauiKit'
url='https://invent.kde.org/maui/agenda'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
-license=(GPL3)
-depends=(akonadi-contacts
- calendarsupport
- eventviews
- kconfig
+license=(LGPL3)
+depends=(akonadi
kcoreaddons
ki18n
- libakonadi
- mauikit-git
+ mauikit-calendar
+ mauikit
qt5-base
qt5-declarative)
makedepends=(git extra-cmake-modules)
@@ -43,4 +40,5 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 "${srcdir}/$_pkgname/licenses/"* -t "${pkgdir}/usr/share/licenses/$_pkgname"
}