summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-09-25 00:12:05 +0200
committerFabioLolix2018-09-25 00:12:05 +0200
commitb9bbedfd60c02c9d4f12471c88b53dc607693070 (patch)
tree6926672d3c10bcd1b2438ba4a51a01df8ec2a42a
downloadaur-b9bbedfd60c02c9d4f12471c88b53dc607693070.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD34
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..226060144ed6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mauikit-git
+ pkgdesc = Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG
+ pkgver = r68.f7abd11
+ pkgrel = 1
+ url = https://mauikit.org/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = unknown
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-svg
+ depends = qt5-quickcontrols2
+ depends = kio
+ provides = mauikit
+ conflicts = mauikit
+ source = mauikit-git::git+https://github.com/maui-project/mauikit
+ sha256sums = SKIP
+
+pkgname = mauikit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ccb3649634
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+
+pkgname=mauikit-git
+pkgver=r68.f7abd11
+pkgrel=1
+pkgdesc='Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG'
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://mauikit.org/"
+license=(unknown) # GPL3 ?
+depends=(qt5-base qt5-declarative qt5-svg qt5-quickcontrols2 kio)
+makedepends=(git cmake extra-cmake-modules)
+provides=(mauikit)
+conflicts=(mauikit)
+source=("${pkgname}::git+https://github.com/maui-project/mauikit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}