summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-01-12 21:46:03 +0100
committerFabioLolix2020-01-12 21:46:03 +0100
commiteaa918dcc4e46745a6f08ef5a574548fd1bfc73c (patch)
treeb0142c64aa848d5e32b2bf2e62c2fec45cd6091c
parente282f1a235529983a8d69bfad4cd4f3f888d9e70 (diff)
downloadaur-eaa918dcc4e46745a6f08ef5a574548fd1bfc73c.tar.gz
Source & makedepends update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a8122d19013..7f0926a5be2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mauikit-git
pkgdesc = Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG
- pkgver = r406.76895b8
+ pkgver = r1047.98e368c
pkgrel = 1
url = https://mauikit.org/
arch = x86_64
@@ -14,6 +14,8 @@ pkgbase = mauikit-git
makedepends = cmake
makedepends = extra-cmake-modules
makedepends = qt5-webengine
+ makedepends = appstream
+ makedepends = syntax-highlighting
depends = qt5-base
depends = qt5-declarative
depends = qt5-svg
@@ -21,7 +23,7 @@ pkgbase = mauikit-git
depends = kio
provides = mauikit
conflicts = mauikit
- source = mauikit-git::git+https://github.com/maui-project/mauikit
+ source = git+https://invent.kde.org/kde/mauikit.git
sha256sums = SKIP
pkgname = mauikit-git
diff --git a/PKGBUILD b/PKGBUILD
index e9f6c0951abf..3509a534019c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=mauikit-git
-pkgver=r406.76895b8
+pkgver=r1047.98e368c
pkgrel=1
pkgdesc='Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://mauikit.org/"
license=(GPL3)
depends=(qt5-base qt5-declarative qt5-svg qt5-quickcontrols2 kio)
-makedepends=(git cmake extra-cmake-modules qt5-webengine)
+makedepends=(git cmake extra-cmake-modules qt5-webengine appstream syntax-highlighting)
provides=(mauikit)
conflicts=(mauikit)
-source=("${pkgname}::git+https://github.com/maui-project/mauikit")
+source=("git+https://invent.kde.org/kde/mauikit.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -29,6 +32,6 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
make DESTDIR="$pkgdir" install
}