summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2022-02-23 18:13:39 +0200
committerDeon Spengler2022-02-23 18:13:39 +0200
commitaf89470be7692a905d987017c19a505a779ed15c (patch)
tree45ea4a018a95f95fb6b4d480eada58815d652098
parente6ad785d02af4e6b7bc3f01119049ac7e63a5bb5 (diff)
downloadaur-af89470be7692a905d987017c19a505a779ed15c.tar.gz
Aligned with the standards of the other bridges
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--mautrix-googlechat-registration2
-rw-r--r--mautrix-googlechat.install6
-rw-r--r--mautrix-googlechat.service2
5 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c8fc8af73b4..d31772e96e0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mautrix-googlechat
pkgdesc = A Matrix-Google Chat puppeting bridge.
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mautrix/googlechat
install = mautrix-googlechat.install
arch = any
@@ -23,7 +23,7 @@ pkgbase = mautrix-googlechat
source = mautrix-googlechat-registration
source = mautrix-googlechat.service
sha256sums = 82c2b3c5acea8a85b0753ccb9c67576b42680f37312832fee537492a9363814e
- sha256sums = fe7b3a6b600d8ed79f55bd15cb1dab2ff52b06b7a0a33b76057d9d2adfa32249
- sha256sums = ae59346bae9bc0601714068b236fdbfbab6a9c363fe11207d01acc8a28f1194a
+ sha256sums = f6693ed10a1d76ef94fdb37801514523ea1809cf0ea71e83c44f5832118237f9
+ sha256sums = 2117e24762e2e8731069020720afff3c6024f506cb6c68c9dd7361262fbcb0e3
pkgname = mautrix-googlechat
diff --git a/PKGBUILD b/PKGBUILD
index 7fe37f3ad593..2ce7656d7ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mautrix-googlechat
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Matrix-Google Chat puppeting bridge."
url="https://github.com/mautrix/googlechat"
depends=(python
@@ -25,8 +25,8 @@ source=("https://github.com/mautrix/googlechat/archive/refs/tags/v${pkgver}.tar.
"mautrix-googlechat-registration"
"mautrix-googlechat.service")
sha256sums=('82c2b3c5acea8a85b0753ccb9c67576b42680f37312832fee537492a9363814e'
- 'fe7b3a6b600d8ed79f55bd15cb1dab2ff52b06b7a0a33b76057d9d2adfa32249'
- 'ae59346bae9bc0601714068b236fdbfbab6a9c363fe11207d01acc8a28f1194a')
+ 'f6693ed10a1d76ef94fdb37801514523ea1809cf0ea71e83c44f5832118237f9'
+ '2117e24762e2e8731069020720afff3c6024f506cb6c68c9dd7361262fbcb0e3')
build() {
cd googlechat-${pkgver}
@@ -37,7 +37,7 @@ package() {
cd googlechat-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm664 ${pkgdir}/usr/example-config.yaml ${pkgdir}/etc/synapse/mautrix-googlechat/config.yaml
+ install -Dm644 ${pkgdir}/usr/example-config.yaml ${pkgdir}/etc/mautrix-googlechat/config.yaml
rm ${pkgdir}/usr/example-config.yaml
install -Dm755 ${srcdir}/mautrix-googlechat-registration ${pkgdir}/usr/bin/mautrix-googlechat-registration
install -Dm644 ${srcdir}/mautrix-googlechat.service ${pkgdir}/usr/lib/systemd/system/mautrix-googlechat.service
diff --git a/mautrix-googlechat-registration b/mautrix-googlechat-registration
index 3e9882054ccf..33200546f6ff 100644
--- a/mautrix-googlechat-registration
+++ b/mautrix-googlechat-registration
@@ -5,4 +5,4 @@ if [[ $EUID -ne 0 ]]; then
exit 1
fi
-python -m mautrix_googlechat -c /etc/synapse/mautrix-googlechat/config.yaml -r /etc/synapse/mautrix-googlechat/registration.yaml -g
+python -m mautrix_googlechat -c /etc/mautrix-googlechat/config.yaml -r /etc/mautrix-googlechat/registration.yaml -g
diff --git a/mautrix-googlechat.install b/mautrix-googlechat.install
index 9093d4ffcb1b..bf57869e5dc3 100644
--- a/mautrix-googlechat.install
+++ b/mautrix-googlechat.install
@@ -1,8 +1,4 @@
post_install() {
- echo "Update the config '/etc/synapse/mautrix-googlechat/config.yaml' to your environment"
- echo "Generate the appservice registration with the following command"
+ echo "Generate the appservice registration.yaml with the following command"
echo " mautrix-googlechat-registration"
- echo "Register the bridge by makeing the following change to homeserver.yaml"
- echo " app_service_config_files:"
- echo " - /etc/synapse/mautrix-googlechat/registration.yaml"
}
diff --git a/mautrix-googlechat.service b/mautrix-googlechat.service
index b695710aa881..658839e3b554 100644
--- a/mautrix-googlechat.service
+++ b/mautrix-googlechat.service
@@ -2,7 +2,7 @@
Description=Mautrix Google Chat bridge
[Service]
-ExecStart=/usr/bin/python -m mautrix_googlechat -c /etc/synapse/mautrix-googlechat/config.yaml
+ExecStart=/usr/bin/python -m mautrix_googlechat -c /etc/mautrix-googlechat/config.yaml
[Install]
WantedBy=multi-user.target