summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA Frederick Christensen2022-10-16 23:37:18 -0500
committerA Frederick Christensen2022-10-16 23:37:18 -0500
commit761487aae8e7bcf30bc9b0774b30c52ccc012dc7 (patch)
tree70c8171be75b56f933747988d4d57a6a0fa00d8e
downloadaur-761487aae8e7bcf30bc9b0774b30c52ccc012dc7.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..842477e723ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mautrix-syncproxy-git
+ pkgdesc = A proxy microservice for Matrix designed to be used with mautrix-wsproxy
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/mautrix/syncproxy
+ arch = x86_64
+ license = AGPL
+ makedepends = go
+ makedepends = git
+ source = mautrix-syncproxy::git+https://github.com/mautrix/syncproxy.git
+ sha256sums = SKIP
+
+pkgname = mautrix-syncproxy-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..becdc439ff26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: A Frederick Christensen <aur@ivories.org>
+
+pkgname=mautrix-syncproxy-git
+_pkgname=mautrix-syncproxy
+pkgver=0
+pkgrel=1
+pkgdesc="A proxy microservice for Matrix designed to be used with mautrix-wsproxy"
+arch=('x86_64')
+license=('AGPL')
+makedepends=('go' 'git')
+url="https://github.com/mautrix/syncproxy"
+source=("${_pkgname}"::"git+https://github.com/mautrix/syncproxy.git")
+sha256sums=('SKIP')
+
+# https://wiki.archlinux.org/title/VCS_package_guidelines :
+# "If there are no tags then use number of revisions since beginning of the history"
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ go build -o "${_pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: