summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2021-06-15 19:57:34 +0200
committerBrainDamage2021-06-15 19:57:34 +0200
commit8439b2ed2f6747aadcd2816e4ef43e14ff2b7d9a (patch)
treee7ad4251b5a84893a9f2a0977da66fe4f3b69078
parent9dd5a33cd149d09e068a4a75b4ac485943e7707c (diff)
downloadaur-8439b2ed2f6747aadcd2816e4ef43e14ff2b7d9a.tar.gz
version bump
added a post-install message about deprecation of sqlite added a post-install message about requirements.txt stripping the package now installs a copy of the original requirements files
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--mautrix-telegram.install5
3 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ecad104f4c2..38c18f3cdb69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mautrix-telegram
pkgdesc = A Matrix-Telegram hybrid puppeting/relaybot bridge.
- pkgver = 0.9.0
- pkgrel = 10
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://github.com/tulir/mautrix-telegram
install = mautrix-telegram.install
arch = any
@@ -16,8 +16,10 @@ pkgbase = mautrix-telegram
depends = python-commonmark
depends = python-aiohttp
depends = python-yarl
- depends = python-mautrix<0.9
- depends = python-telethon<1.18
+ depends = python-mautrix>=0.9.3
+ depends = python-mautrix<0.10
+ depends = python-telethon>=1.20
+ depends = python-telethon<1.22
depends = python-telethon-session-sqlalchemy
optdepends = python-cryptg: faster encryption
optdepends = python-cchardet: faster encoding detection
@@ -34,11 +36,11 @@ pkgbase = mautrix-telegram
optdepends = python-unpaddedbase64: end-to-bridge encryption support
backup = etc/mautrix-telegram/config.yaml
backup = etc/mautrix-telegram/registration.yaml
- source = https://github.com/tulir/mautrix-telegram/archive/v0.9.0.tar.gz
+ source = https://github.com/tulir/mautrix-telegram/archive/v0.10.0.tar.gz
source = mautrix-telegram.service
source = mautrix-telegram.sysusers
source = mautrix-telegram.tmpfiles
- sha256sums = e0fb30bf448f1bec6f27f73662c1dcddd36986367dcbe4f34509b23af67142a9
+ sha256sums = a9d09d6cd1f13074aa844114db9939dfb75ca1dc898467535d66208c7568209f
sha256sums = a419168bff80e469f2f4e26279afae77d92e6ae86c2457696e1ca9fc6ba1cb12
sha256sums = fce0a4f792e62d9440fe431fb6ab6c458139bcc801bc2b02bc1b3d8f2ff9fcbf
sha256sums = 2f5c45f6b0a9d1ae5237a91bdcb527609d262bc27cb7fa1dc736b4103ee230e5
diff --git a/PKGBUILD b/PKGBUILD
index cd2947cd7cd2..7b646b1e39eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: BrainDamage
pkgname=mautrix-telegram
-pkgver=0.9.0
-pkgrel=10
+pkgver=0.10.0
+pkgrel=1
pkgdesc="A Matrix-Telegram hybrid puppeting/relaybot bridge."
url="https://github.com/tulir/mautrix-telegram"
depends=('python' 'python-sqlalchemy' 'python-alembic' 'python-ruamel-yaml'
'python-magic-ahupp' 'python-commonmark' 'python-aiohttp' 'python-yarl'
- 'python-mautrix<0.9' 'python-telethon<1.18' 'python-telethon-session-sqlalchemy')
+ 'python-mautrix>=0.9.3' 'python-mautrix<0.10' 'python-telethon>=1.20'
+ 'python-telethon<1.22' 'python-telethon-session-sqlalchemy')
makedepends=('python-setuptools' 'python-pytest-runner')
optdepends=('python-cryptg: faster encryption'
'python-cchardet: faster encoding detection'
@@ -24,7 +25,7 @@ optdepends=('python-cryptg: faster encryption'
license=('AGPLv3')
arch=('any')
source=("${url}/archive/v${pkgver}.tar.gz" "${pkgname}.service" "${pkgname}.sysusers" "${pkgname}.tmpfiles")
-sha256sums=('e0fb30bf448f1bec6f27f73662c1dcddd36986367dcbe4f34509b23af67142a9'
+sha256sums=('a9d09d6cd1f13074aa844114db9939dfb75ca1dc898467535d66208c7568209f'
'a419168bff80e469f2f4e26279afae77d92e6ae86c2457696e1ca9fc6ba1cb12'
'fce0a4f792e62d9440fe431fb6ab6c458139bcc801bc2b02bc1b3d8f2ff9fcbf'
'2f5c45f6b0a9d1ae5237a91bdcb527609d262bc27cb7fa1dc736b4103ee230e5')
@@ -37,6 +38,8 @@ prepare() {
# the author makes liberal usage of max version for requirements without a real need
# we'll strip them and re-introduce in the deps/optdeps array if truly necessary
# to prevent a nightmare during updates while tracking stable releases
+ cp requirements.txt ../requirements.txt.orig
+ cp optional-requirements.txt ../optional-requirements.txt.orig
sed -i -E 's/,?<[[:digit:]]*\.?[[:digit:]]+,?//g' requirements.txt
sed -i -E 's/,?<[[:digit:]]*\.?[[:digit:]]+,?//g' optional-requirements.txt
# create an empty registration file so that permissions get written properly from the get go
@@ -60,6 +63,10 @@ package() {
# which would make them conflict eachother
rm -rf "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/tests"
+ # install the original requirements file, useful as documentation
+ install -Dvm 644 "${srcdir}/requirements.txt.orig" "$(find ${pkgdir} -name 'requires.txt' -printf '%h')"
+ install -Dvm 644 "${srcdir}/optional-requirements.txt.orig" "$(find ${pkgdir} -name 'requires.txt' -printf '%h')"
+
# adjust alembic script dir location so that by using an abs path it can be used in CWD
sed -i -e "s|script_location = alembic|script_location = ${_shared_dir}/alembic/|" "${pkgdir}${_shared_dir}/alembic.ini"
diff --git a/mautrix-telegram.install b/mautrix-telegram.install
index 57dce084b8a9..a03bdda55a7b 100644
--- a/mautrix-telegram.install
+++ b/mautrix-telegram.install
@@ -1,6 +1,11 @@
post_install() {
cat <<- 'EOF'
+ this package strips max version for packages in requirements.txt; Arch tracks stable releases and the author enforces max versions as a precautionary measure, as consequence the package would get unable to build in short time without this workaround, where necessary the enforcement has been copied to the pkgbuild, however the information may get outdated as libraries get upgraded and break their API
+ the original files have been installed as well to act as documentation in the case a user finds compatibility problems
+
after editing /etc/mautrix-telegram/config.yaml, generate a registration file using:
# mautrix-telegram -b /usr/share/mautrix-telegram/example-config.yaml -c /etc/mautrix-telegram/config.yaml -r /etc/mautrix-telegram/registration.yaml -g
+
+ this is the last version of mautrix-telegram supporting sqlite, please refer to the release notes for db migration: https://github.com/tulir/mautrix-telegram/releases/tag/v0.10.0
EOF
}