summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Meiseberg2020-07-15 16:35:22 +0000
committerRobin Meiseberg2020-07-15 16:37:42 +0000
commit9ea50eb94997c214902b43d26293bfc1a691ad6c (patch)
tree06f921a10d58942462796ae5f499bd70f44d0dc4
downloadaur-9ea50eb94997c214902b43d26293bfc1a691ad6c.tar.gz
Add build script vor may v1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db41e33e3ce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = may
+ pkgdesc = CLI tool to easily list and manage git repositories all across your system.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/robin-mbg/may
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ source = https://github.com/robin-mbg/may/archive/v1.0.0.tar.gz
+ sha256sums = 48fc67a805add03bca8af263f62e72c6a4e6d989d635faa00f3d1c93f4fd8c9c
+
+pkgname = may
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b015a6301927
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=may
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='CLI tool to easily list and manage git repositories all across your system.'
+arch=('x86_64')
+url="https://github.com/robin-mbg/$pkgname"
+license=('GPL')
+makedepends=('go')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('48fc67a805add03bca8af263f62e72c6a4e6d989d635faa00f3d1c93f4fd8c9c')
+
+build() {
+ cd $pkgname-$pkgver
+ go mod vendor
+ go build \
+ -mod=vendor \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname ./cmd/may
+}
+
+check() {
+ cd $pkgname-$pkgver
+ may -V
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}