summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Zhou2022-04-15 23:54:11 -0400
committerRobert Zhou2022-04-15 23:54:11 -0400
commit3756cc20c9496044ec53ee065fe059efe010628f (patch)
tree4d4a250698c039eae531586eb740b4237bfb1655
parent5e1efdbd23ea64ba72f39301ce8f2e23d9b15914 (diff)
downloadaur-3756cc20c9496044ec53ee065fe059efe010628f.tar.gz
Update to 5.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f624b4413fa9..02bbd575a9d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = maya-arnold
pkgdesc = Autodesk Maya Arnold Renderer Plugin
- pkgver = 4.2.1
+ pkgver = 5.1.0
pkgrel = 1
url = https://www.arnoldrenderer.com/arnold/arnold-for-maya/
arch = x86_64
license = custom
- depends = maya>=2022.0
- depends = maya<2023.0
+ depends = maya>=2023.0
+ depends = maya<2024.0
depends = smbclient
depends = tbb
optdepends = maya-usd: Universal Scene Discription Support
options = !strip
source = manual://package.zip
- sha256sums = f5802a922d5960f2465963f9221e4377ea2daa70482db89076defa68ea478a39
+ sha256sums = 4e2ed84e6c10eed69f7b079f62077d15010641224d28154ae30c844526306bb8
pkgname = maya-arnold
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4a9b021e4790
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+*.zst
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index fece971c7627..c7b84870c348 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: William Tang <galaxyking0419@gmail.com>
pkgname=maya-arnold
-pkgver=4.2.1
+pkgver=5.1.0
pkgrel=1
pkgdesc='Autodesk Maya Arnold Renderer Plugin'
arch=('x86_64')
url='https://www.arnoldrenderer.com/arnold/arnold-for-maya/'
license=('custom')
-depends=('maya>=2022.0' 'maya<2023.0' 'smbclient' 'tbb')
+depends=('maya>=2023.0' 'maya<2024.0' 'smbclient' 'tbb')
optdepends=('maya-usd: Universal Scene Discription Support')
DLAGENTS+=('manual::/usr/bin/echo \ \ Note: Please download the package manually from the official website')
source=('manual://package.zip')
-sha256sums=('f5802a922d5960f2465963f9221e4377ea2daa70482db89076defa68ea478a39')
+sha256sums=('4e2ed84e6c10eed69f7b079f62077d15010641224d28154ae30c844526306bb8')
options=(!strip)
prepare() {
- sed -i 's|/jenkins/workspace/Arnold-MTOA_Build_LINUX_CENTOS73/MTOA_DEPLOY|/usr/autodesk/maya2022/plug-ins/arnold|g' mtoa.mod
+ sed -i 's|/home/go-agent/pipelines/MtoA-5.1.0/material/mtoa/MTOA_DEPLOY|/usr/autodesk/maya2023/plug-ins/arnold|g' mtoa.mod
}
package() {
unlink package.zip
- mkdir -p $pkgdir/usr/autodesk/maya2022/{modules,plug-ins/arnold}
+ mkdir -p $pkgdir/usr/autodesk/maya2023/{modules,plug-ins/arnold}
- mv mtoa.mod $pkgdir/usr/autodesk/maya2022/modules/
- mv * $pkgdir/usr/autodesk/maya2022/plug-ins/arnold/
+ mv mtoa.mod $pkgdir/usr/autodesk/maya2023/modules/
+ mv * $pkgdir/usr/autodesk/maya2023/plug-ins/arnold/
}