summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Zhou2022-12-18 02:07:52 -0800
committerRobert Zhou2022-12-18 02:07:52 -0800
commit7919f1bd9eb67f72365e40e27f20535d60c45218 (patch)
tree67784511cb8012f509b607b874a821f949a9560a
parent29938ea042c679f6b811eaad6dbdb68e07871599 (diff)
downloadaur-7919f1bd9eb67f72365e40e27f20535d60c45218.tar.gz
Update to 0.20.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--updateSchemaWithSdrNode-onload-SyntaxError.patch12
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f43505f873c..a8d2b4fb42b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = maya-usd
pkgdesc = Autodesk Maya Universal Scene Discription Plugin
- pkgver = 0.19.0
+ pkgver = 0.20.0
pkgrel = 1
url = https://github.com/Autodesk/maya-usd
arch = x86_64
@@ -8,7 +8,9 @@ pkgbase = maya-usd
depends = maya>=2023.0
depends = maya<2024.0
options = !strip
- source = manual://MayaUSD2023-202208051814-6d974fb-0.19.0-1.x86_64.rpm
- sha256sums = 152e14d9fdc1a573915f494308ee837c14fb6efa74a476c2496d990fac9a4ef2
+ source = manual://MayaUSD2023-202211021008-b68700b-0.20.0-1.x86_64.rpm
+ source = updateSchemaWithSdrNode-onload-SyntaxError.patch
+ sha256sums = dfa10f772743172bb42770cb14bef8858b49121bf33585e635264d7b6b2be83c
+ sha256sums = 3a0be2176751dd51933d7ac6896324f674fa3c3120d520c21f51257d7c1c7c1e
pkgname = maya-usd
diff --git a/PKGBUILD b/PKGBUILD
index acd58afa5386..9809bd9e8910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_mayaver=2023
pkgname=maya-usd
-pkgver=0.19.0
+pkgver=0.20.0
pkgrel=1
pkgdesc='Autodesk Maya Universal Scene Discription Plugin'
arch=('x86_64')
@@ -12,18 +12,21 @@ license=('custom')
depends=('maya>=2023.0' 'maya<2024.0')
DLAGENTS+=('manual::/usr/bin/echo \ \ Note: Please download the package manually from the official website')
-source=("manual://MayaUSD$_mayaver-202208051814-6d974fb-$pkgver-1.x86_64.rpm")
-sha256sums=('152e14d9fdc1a573915f494308ee837c14fb6efa74a476c2496d990fac9a4ef2')
+source=("manual://MayaUSD$_mayaver-202211021008-b68700b-$pkgver-1.x86_64.rpm"
+ "updateSchemaWithSdrNode-onload-SyntaxError.patch")
+sha256sums=('dfa10f772743172bb42770cb14bef8858b49121bf33585e635264d7b6b2be83c'
+ '3a0be2176751dd51933d7ac6896324f674fa3c3120d520c21f51257d7c1c7c1e')
options=(!strip)
prepare() {
sed -i "s|<PLUGIN_DIR>|/usr/autodesk/maya$_mayaver/plug-ins/mayausd|g" usr/autodesk/modules/maya/$_mayaver/mayausd.mod
sed -i 's/\$MAYA_PYTHON_VERSION/3/g' usr/autodesk/modules/maya/$_mayaver/mayausd.mod
+ patch --directory="usr" --forward --strip=1 --input="${srcdir}/updateSchemaWithSdrNode-onload-SyntaxError.patch"
}
package() {
mkdir -p $pkgdir/usr/autodesk/maya$_mayaver/{modules,plug-ins/mayausd}
mv usr/autodesk/modules/maya/$_mayaver/mayausd.mod $pkgdir/usr/autodesk/maya$_mayaver/modules/
- mv usr/autodesk/mayausd/maya$_mayaver/${pkgver}_202208051814-6d974fb/mayausd/* $pkgdir/usr/autodesk/maya$_mayaver/plug-ins/mayausd/
+ mv usr/autodesk/mayausd/maya$_mayaver/${pkgver}_202211021008-b68700b/mayausd/* $pkgdir/usr/autodesk/maya$_mayaver/plug-ins/mayausd/
}
diff --git a/updateSchemaWithSdrNode-onload-SyntaxError.patch b/updateSchemaWithSdrNode-onload-SyntaxError.patch
new file mode 100644
index 000000000000..842ad41b84f6
--- /dev/null
+++ b/updateSchemaWithSdrNode-onload-SyntaxError.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text usr.orig/autodesk/mayausd/maya2023/0.20.0_202211021008-b68700b/mayausd/USD/lib/python/pxr/UsdUtils/updateSchemaWithSdrNode.py usr.new/autodesk/mayausd/maya2023/0.20.0_202211021008-b68700b/mayausd/USD/lib/python/pxr/UsdUtils/updateSchemaWithSdrNode.py
+--- usr.orig/autodesk/mayausd/maya2023/0.20.0_202211021008-b68700b/mayausd/USD/lib/python/pxr/UsdUtils/updateSchemaWithSdrNode.py 2022-11-02 10:13:29.000000000 -0700
++++ usr.new/autodesk/mayausd/maya2023/0.20.0_202211021008-b68700b/mayausd/USD/lib/python/pxr/UsdUtils/updateSchemaWithSdrNode.py 2022-12-18 02:02:18.304276565 -0800
+@@ -369,7 +369,7 @@
+ sdrNode.GetContext(), PropertyDefiningKeys.SHADER_ID)
+ sdrIdentifier = primDef.GetAttributeFallbackValue(
+ shaderIdAttrName)
+- if sdrIdentifier is not "":
++ if sdrIdentifier != "":
+ usdSchemaNode = reg.GetNodeByIdentifierAndType(
+ sdrIdentifier,
+ SchemaDefiningMiscConstants.USD_SOURCE_TYPE)