summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2020-01-27 22:15:57 +0100
committerMarius Lindvall2020-01-27 22:15:57 +0100
commite1bfbfe3738fdf750cd9ce97d35f64b564d82cbe (patch)
treecd530bfb55b75bb0caeb1237cfed74c8eca890e8
downloadaur-e1bfbfe3738fdf750cd9ce97d35f64b564d82cbe.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD28
-rwxr-xr-xmazespheres.sh2
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b74a0822c35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mazespheres-bin
+ pkgdesc = A horror-themed minimalistic maze game
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://varden.info/product.php?sid=27
+ arch = x86_64
+ license = custom
+ source = https://varden.info/~m/aur/Mazespheres-Linux-v1.1.tar.xz
+ source = LICENSE
+ source = mazespheres.sh
+ sha256sums = 180dbe7369e6116d000698e2d3e77b8a3913bface1f21db6f59cdf689998a3d2
+ sha256sums = f8c94c4c62bf8e900ac22bea2b17c7e5e2540cc2d09d4ee8e05dedb378cbd7d3
+ sha256sums = 3b698333e28f1cff1703e2109abc425228163c06339ed18794e8422931751c48
+
+pkgname = mazespheres-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c37e83c7d5b1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,2 @@
+Copyright © Marius Lindvall 2017-2020.
+All rights reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..564c7d5f247d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+
+pkgname=mazespheres-bin
+pkgver=1.1
+pkgrel=1
+pkgdesc='A horror-themed minimalistic maze game'
+
+url='https://varden.info/product.php?sid=27'
+arch=('x86_64')
+license=('custom')
+
+depends=()
+optdepends=()
+conflicts=()
+source=("https://varden.info/~m/aur/Mazespheres-Linux-v1.1.tar.xz"
+ "LICENSE"
+ "mazespheres.sh")
+sha256sums=("180dbe7369e6116d000698e2d3e77b8a3913bface1f21db6f59cdf689998a3d2"
+ "f8c94c4c62bf8e900ac22bea2b17c7e5e2540cc2d09d4ee8e05dedb378cbd7d3"
+ "3b698333e28f1cff1703e2109abc425228163c06339ed18794e8422931751c48")
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt/Mazespheres"
+ mv Mazespheres_Linux.x86_64 Mazespheres_Linux_Data "$pkgdir/opt/Mazespheres"
+ install -Dm 755 "mazespheres.sh" "$pkgdir/usr/bin/mazespheres"
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/mazespheres-bin/LICENSE"
+}
diff --git a/mazespheres.sh b/mazespheres.sh
new file mode 100755
index 000000000000..e9dd44feedcf
--- /dev/null
+++ b/mazespheres.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/Mazespheres/Mazespheres_Linux.x86_64