summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Zanoni2024-03-12 16:15:08 +0100
committerAndrea Zanoni2024-03-12 16:15:08 +0100
commit29f945a5ec9c5575eb3cbd4a695cfb378b56bae6 (patch)
treee91521b7877f86138a387f38fc98ebbda0a75d64
parent7e833f401c91b317c2c0c51d1e59d576a7caffa7 (diff)
downloadaur-29f945a5ec9c5575eb3cbd4a695cfb378b56bae6.tar.gz
Moved CPPFLAGS and LDFLAGS in the correct place, removed unnecessary stuff
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD41
2 files changed, 19 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2e3abde5dfc..a1e9375c349f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mbdyn-git
pkgdesc = The first *free* general purpose Multibody Dynamics analysis software
- pkgver = r8465.53a8e2a5a
+ pkgver = r8479.eb3297c34
pkgrel = 1
url = www.mbdyn.org
install = mbdyn.install
@@ -17,6 +17,7 @@ pkgbase = mbdyn-git
optdepends = ginac: symbolic elements support,
optdepends = lapack: eigenanalysis support,
optdepends = blas-openblas: eigenanalysis support, openBLAS version
+ options = buildflags
source = mbdyn-git::git+https://public.gitlab.polimi.it/DAER/mbdyn.git#branch=develop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3d8c8ae0e3b3..30e15cc7b017 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrea Zanoni <andrea dot zanoni at polimi dot it>
pkgname=mbdyn-git
-pkgver=r8465.53a8e2a5a
+pkgver=r8479.eb3297c34
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
@@ -13,11 +13,12 @@ license=('GPLv2')
depends=(suitesparse netcdf netcdf-cxx)
makedepends=(git autoconf automake gcc-fortran libtool)
optdepends=('ginac: symbolic elements support',
- 'lapack: eigenanalysis support',
- 'blas-openblas: eigenanalysis support, openBLAS version')
+ 'lapack: eigenanalysis support',
+ 'blas-openblas: eigenanalysis support, openBLAS version')
source=("${pkgname}::git+https://public.gitlab.polimi.it/DAER/mbdyn.git#branch=develop")
install=mbdyn.install
sha256sums=('SKIP')
+options=(buildflags)
# Note: edit the list of modules to suit your needs
_modules="hfelem"
@@ -29,36 +30,28 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- patch --forward --strip=1 --input="${srcdir}/mbdyn-utils-aur.patch"
sh bootstrap.sh
- CXXFLAGS="-O3 -march=native" \
- FCFLAGS="-O3" \
- CFLAGS="-O3 -march=native" \
- ./configure \
- --with-module="${_modules}" \
- --prefix=/usr \
- --with-y12=no \
- --with-lapack=yes \
- --enable-python \
- --enable-Werror=no \
- --with-superlu=no \
- --enable-runtime-loading \
- --libexecdir=/usr/lib/${pkgname::}
- perl -p -i -e 's#^(\s*libfile=")(\$libdir/)#$1\$DESTDIR$2#' libtool
- perl -p -i -e 's#^(\s*if test "X\$destdir" = "X)(\$libdir")#$1\$DESTDIR$2#' libtool
- cd ${srcdir}/${pkgname}/modules
- perl -p -i -e 's#^(\s*libfile=")(\$libdir/)#$1\$DESTDIR$2#' libtool
- perl -p -i -e 's#^(\s*if test "X\$destdir" = "X)(\$libdir")#$1\$DESTDIR$2#' libtool
}
build() {
cd ${srcdir}/${pkgname}
+ CPPFLAGS+=" -I/usr/include/suitesparse/"
+ LDFLAGS+=" -rdynamic -lsuitesparseconfig"
+ ./configure \
+ --with-module="${_modules}" \
+ --prefix=/usr \
+ --with-y12=no \
+ --with-lapack=yes \
+ --enable-python \
+ --enable-Werror=no \
+ --with-superlu=no \
+ --enable-runtime-loading \
+ --libexecdir=/usr/lib/${pkgname::-4}
make -j$(nproc) all
}
package() {
cd ${srcdir}/${pkgname}
mkdir -p "${pkgdir}/usr/lib/${pkgname::-4}"
- libtool --finish "${pkgdir}/usr/lib/${pkgname::-4}"
- make DESTDIR=${pkgdir} install
+ sudo make install
}