summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Zanoni2024-03-04 22:10:16 +0100
committerAndrea Zanoni2024-03-04 22:10:16 +0100
commitc4bc586f6845663b98e05e0f8241295260abd450 (patch)
tree691a75256fb3028ebaa7e8984a0e38ef4b416fbb
parent16f9c54c63dd34e26c3c7481ab984780475a2766 (diff)
downloadaur-c4bc586f6845663b98e05e0f8241295260abd450.tar.gz
Added automatic version bump, and automatic checkout of develop branch
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adcd3dc6fc34..c0f80bdd73fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,10 @@
# Maintainer: Andrea Zanoni <andrea dot zanoni at polimi dot it>
pkgname=mbdyn-git
-pkgver=r7415.ebbccab59
+pkgver=r8465.53a8e2a5a
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
pkgrel=1
pkgdesc="The first *free* general purpose Multibody Dynamics analysis software"
arch=('any')
@@ -9,7 +13,7 @@ license=('GPLv2')
depends=(openblas-lapack suitesparse netcdf netcdf-cxx)
makedepends=(git autoconf automake gcc-fortran libtool)
optdepends=('ginac: symbolic elements support')
-source=("${pkgname}::git+https://public.gitlab.polimi.it/DAER/mbdyn.git")
+source=("${pkgname}::git+https://public.gitlab.polimi.it/DAER/mbdyn.git#branch=develop")
sha256sums=('SKIP')
# Note: edit the list of modules to suit your needs
@@ -22,19 +26,18 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- git checkout develop
sh bootstrap.sh
CXXFLAGS="-O3 -march=native" \
- FCFLAGS="-O3" \
- CFLAGS="-O3 -march=native" \
- ./configure \
- --with-module="${_modules}" \
- --prefix=/usr \
- --with-y12=no \
- --with-lapack=yes \
- --enable-python \
- --enable-Werror=no \
- --with-superlu=no
+ FCFLAGS="-O3" \
+ CFLAGS="-O3 -march=native" \
+ ./configure \
+ --with-module="${_modules}" \
+ --prefix=/usr \
+ --with-y12=no \
+ --with-lapack=yes \
+ --enable-python \
+ --enable-Werror=no \
+ --with-superlu=no
}
build() {