summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 18:55:07 +0200
committerMuflone2015-06-13 18:55:07 +0200
commit52619af83c35f0d7c44219884afb36ae28243afd (patch)
treea8a2285e1ba0f037bfde08cfff3cd81b84144e98
downloadaur-52619af83c35f0d7c44219884afb36ae28243afd.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..669c34f3f36c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mbrola
+ pkgdesc = A phoneme-to-audio converter used by many TTS (Text-to-speech) programs
+ pkgver = 3.0.1h
+ pkgrel = 5
+ url = http://tcts.fpms.ac.be/synthesis/mbrola.html
+ arch = i686
+ arch = x86_64
+ license = custom:Mbrola
+ source = http://tcts.fpms.ac.be/synthesis/mbrola/bin/pclinux/mbr301h.zip
+ sha256sums = df402fad97c823206fce68837c1d716b9c0466a4cfb554dfb244df7da5589d6e
+ depends_i686 = glibc
+ depends_x86_64 = lib32-glibc
+
+pkgname = mbrola
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c42b74f145c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Simone Sclavi 'Ito' <darkhado@gmail.com>
+# Contributor: Changaco <changaco@changaco.net>
+
+pkgname=mbrola
+pkgver=3.0.1h
+pkgrel=5
+pkgdesc="A phoneme-to-audio converter used by many TTS (Text-to-speech) programs"
+arch=('i686' 'x86_64')
+url="http://tcts.fpms.ac.be/synthesis/mbrola.html"
+license=('custom:Mbrola')
+depends_i686=('glibc')
+depends_x86_64=('lib32-glibc')
+source=("http://tcts.fpms.ac.be/synthesis/${pkgname}/bin/pclinux/mbr${pkgver//./}.zip")
+sha256sums=('df402fad97c823206fce68837c1d716b9c0466a4cfb554dfb244df7da5589d6e')
+
+build() {
+ # Prepare license file
+ sed -n '/This program and object/,/2.0 A brief description of MBROLA/p' readme.txt | head -n -1 > "LICENSE"
+}
+
+package() {
+ # Install executable file
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 "mbrola-linux-i386" "${pkgdir}/usr/bin/${pkgname}"
+ # Install license file
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "LICENSE"
+ # Install documentation file
+ install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "readme.txt"
+}
+