summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matos2019-01-18 09:32:29 +0100
committerPaulo Matos2019-01-18 09:32:29 +0100
commit92824211cc8440da9af334ba4ccb5a11044ebfce (patch)
treed2d4cd2dd52e5be3d7085474e87de72854b372b6
downloadaur-92824211cc8440da9af334ba4ccb5a11044ebfce.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad0f7d945fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mbsync-git
+ pkgdesc = free (GPL) mailbox synchronization program
+ pkgver = 912.95d18e2
+ pkgrel = 1
+ url = http://isync.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ depends = openssl
+ provides = mbsync
+ source = mbsync::git+https://git.code.sf.net/p/isync/isync.git
+ sha256sums = SKIP
+
+pkgname = mbsync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3723d1f13c2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Paulo Matos <pmatos@linki.tools>
+
+pkgname='mbsync-git'
+_pkgname='mbsync'
+pkgver=912.95d18e2
+pkgrel=1
+pkgdesc="free (GPL) mailbox synchronization program"
+arch=('i686' 'x86_64')
+url="http://isync.sourceforge.net/"
+license=('GPL')
+depends=('openssl')
+makedepends=('git' 'autoconf' 'automake')
+provides=('mbsync')
+source=("$_pkgname::git+https://git.code.sf.net/p/isync/isync.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ # Autogen
+ ./autogen.sh
+}
+
+build() {
+ cd ${pkgname%-git}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file