summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Reimer2016-01-03 18:04:14 -0600
committerJeromy Reimer2016-01-03 18:04:14 -0600
commit6063f8bdb48f761ae4a7c9a62a80c68b77db1590 (patch)
treeabb146f347d954712bff0aaf9c69c5d81c251b3c
parentc71bb9edab3bd9121e6cc8d76505e8280f6fa138 (diff)
downloadaur-6063f8bdb48f761ae4a7c9a62a80c68b77db1590.tar.gz
updated to 1.5.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--directories.patch12
-rw-r--r--filters-in-home.patch32
-rw-r--r--numpy1.7-compatibility.patch116
5 files changed, 15 insertions, 174 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7ed08a1cf8a..e03fb06716b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:48:51 UTC 2015
+# Mon Jan 4 00:03:57 UTC 2016
pkgbase = mcedit
pkgdesc = Minecraft world editor
- pkgver = 1.4.0.1
- pkgrel = 2
+ pkgver = 1.5.0.0
+ pkgrel = 1
url = https://github.com/mcedit/mcedit
arch = any
license = BSD
@@ -21,13 +21,11 @@ pkgbase = mcedit
source = MCEdit
source = MCEdit.desktop
source = directories.patch
- source = numpy1.7-compatibility.patch
- source = https://github.com/Khroki/MCEdit-Unified/archive/1.4.0.1.tar.gz
+ source = https://github.com/Khroki/MCEdit-Unified/archive/1.5.0.0.tar.gz
md5sums = b08f609c8923067b13a9bd462999a6f4
md5sums = 53fe3c41d58fd1f6429f90ba0b1831ac
- md5sums = 657f128f31d8818c2fda7e2c02a69149
- md5sums = 2a168455d07a33134b58e44bedeb6e52
- md5sums = f89ddd094dc7819d54090d659d091e5b
+ md5sums = 329f0dbdedd309e4dc121ad3d728e608
+ md5sums = a2f3f43ac68a53aa0ffa48f3ba6b69fe
pkgname = mcedit
diff --git a/PKGBUILD b/PKGBUILD
index 5b600f99f5e9..a947547023e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname='mcedit'
reponame='MCEdit-Unified'
-pkgver='1.4.0.1'
-pkgrel=2
+pkgver='1.5.0.0'
+pkgrel=1
pkgdesc='Minecraft world editor'
arch=('any')
url='https://github.com/mcedit/mcedit'
@@ -17,7 +17,6 @@ conflicts=('mcedit-git' 'pymclevel-git')
source=(MCEdit MCEdit.desktop
directories.patch
- numpy1.7-compatibility.patch
https://github.com/Khroki/${reponame}/archive/${pkgver}.tar.gz
)
@@ -28,8 +27,6 @@ prepare() {
grep -rlZ DejaVuSans\-Regular\.ttf * | while IFS= read -r -d '' filename; do sed -i 's/DejaVuSans\-Regular\.ttf/DejaVuSans\.ttf/g' "$filename"; done
msg directories.patch
patch -Np0 -i ../directories.patch || return 1
- msg numpy1.7-compatibility.patch
- patch -Np0 -i ../numpy1.7-compatibility.patch || return 1
}
@@ -56,7 +53,8 @@ package() {
done
# Images and stuff
- echo "/usr/share/mcedit/splashes/splash1.png" > splash
+ rm -f splash
+ touch splash
cp *.png "${pkgdir}/usr/share/mcedit"
for i in stock-schematics toolicons stock-filters stock-brushes lang\
item-textures Items splashes splash bo3.def RELEASE-VERSION.json\
@@ -72,6 +70,5 @@ package() {
md5sums=('b08f609c8923067b13a9bd462999a6f4'
'53fe3c41d58fd1f6429f90ba0b1831ac'
- '657f128f31d8818c2fda7e2c02a69149'
- '2a168455d07a33134b58e44bedeb6e52'
- 'f89ddd094dc7819d54090d659d091e5b')
+ '329f0dbdedd309e4dc121ad3d728e608'
+ 'a2f3f43ac68a53aa0ffa48f3ba6b69fe')
diff --git a/directories.patch b/directories.patch
index d21c412910a0..7a854af36a81 100644
--- a/directories.patch
+++ b/directories.patch
@@ -78,15 +78,9 @@
pass
self._resource_packs = setup_resource_packs()
---- splash.py.orig 2015-12-24 20:53:55.930654329 -0700
-+++ splash.py 2015-12-24 21:29:44.017385005 -0700
-@@ -21,12 +21,12 @@
- # if os.path.exists(splash_name) and len(open(splash_name).read()) > 0:
- # splash = pygame.image.load(open(splash_name).read().strip())
- # else:
-- splash = pygame.image.load(open(os.path.join(cur_dir, "splash.png"), 'rb'))
-+ splash = pygame.image.load(open(os.path.join("/usr/share/mcedit/", "splash.png"), 'rb'))
- screen = pygame.display.set_mode(splash.get_size(), pygame.NOFRAME)
+--- splash.py.orig 2016-01-03 17:30:26.530655811 -0600
++++ splash.py 2016-01-03 17:32:52.887326839 -0600
+@@ -26,7 +26,7 @@
screen.blit(splash, (0, 0))
except IOError:
try:
diff --git a/filters-in-home.patch b/filters-in-home.patch
deleted file mode 100644
index 565358090283..000000000000
--- a/filters-in-home.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- editortools/filter.py.orig 2013-08-30 11:27:03.192204427 +0200
-+++ editortools/filter.py 2013-08-30 11:29:30.482476023 +0200
-@@ -365,7 +365,10 @@
-
- def reloadFilters(self):
- filterDir = mcplatform.filtersDir
-+ userFilterDir = mcplatform.userFiltersDir
- filterFiles = os.listdir(filterDir)
-+ if os.path.exists(userFilterDir):
-+ filterFiles += os.listdir(userFilterDir)
- filterPyfiles = filter(lambda x: x.endswith(".py"), filterFiles)
-
- def tryImport(name):
---- mcplatform.py.orig 2013-04-26 01:02:44.000000000 +0200
-+++ mcplatform.py 2013-08-30 11:26:34.187710099 +0200
-@@ -419,12 +427,14 @@
- portable = False
-
- filtersDir = os.path.join(directories.dataDir, "filters")
--if filtersDir not in [s.decode(sys.getfilesystemencoding())
-+userFiltersDir = os.path.expanduser("~/.mcedit/filters")
-+for d in [ userFiltersDir, filtersDir ] :
-+ if d not in [s.decode(sys.getfilesystemencoding())
- if isinstance(s, str)
- else s
- for s in sys.path]:
-
-- sys.path.append(filtersDir.encode(sys.getfilesystemencoding()))
-+ sys.path.append(d.encode(sys.getfilesystemencoding()))
-
- if portable:
- serverJarStorageDir = (os.path.join(parentDir, "ServerJarStorage"))
diff --git a/numpy1.7-compatibility.patch b/numpy1.7-compatibility.patch
deleted file mode 100644
index 438192df8cc7..000000000000
--- a/numpy1.7-compatibility.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-# Patch for compatibility with new, Arch's default version of numpy
-
---- renderer.py.orig 2015-08-12 07:12:26.000000000 -0600
-+++ renderer.py 2015-12-24 19:47:05.717201498 -0700
-@@ -227,6 +227,12 @@
- from config import config
- # import time
-
-+def numpy17_combine_colors(target, colors):
-+ """ Combines colors without upseting new version of numpy """
-+ target = numpy.array(target, "f")
-+ target *= colors
-+ target = numpy.array(target, "uint8")
-+ return target
-
- def chunkMarkers(chunkSet):
- """ Returns a mapping { size: [position, ...] } for different powers of 2
-@@ -1570,7 +1576,7 @@
- va1[_XYZ][:, :, 0] *= step
- va1[_XYZ][:, :, 2] *= step
-
-- flatcolors *= 0.8
-+ flatcolors = flatcolors * 0.8
-
- va1.view('uint8')[_RGBA] = flatcolors
- grassmask = topBlocks[nonAirBlocks] == 2
-@@ -1617,7 +1623,8 @@
- if self.materials.name in ("Alpha", "Pocket"):
- if direction == pymclevel.faces.FaceYIncreasing:
- grass = theseBlocks == pymclevel.materials.alphaMaterials.Grass.ID
-- vertexArray.view('uint8')[_RGB][grass] *= self.grassColor
-+ vertexArray.view('uint8')[_RGB][grass] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][grass], self.grassColor)
- yield
-
- vertexArrays.append(vertexArray)
-@@ -1688,12 +1695,18 @@
-
- vertexArray.view('uint8')[_RGB] *= facingBlockLight[blockIndices][..., numpy.newaxis, numpy.newaxis]
- if self.materials.name in ("Alpha", "Pocket"):
-- vertexArray.view('uint8')[_RGB][leaves] *= self.leafColor
-- vertexArray.view('uint8')[_RGB][pines] *= self.pineLeafColor
-- vertexArray.view('uint8')[_RGB][birches] *= self.birchLeafColor
-- vertexArray.view('uint8')[_RGB][jungle] *= self.jungleLeafColor
-- vertexArray.view('uint8')[_RGB][acacia] *= self.acaciaLeafColor
-- vertexArray.view('uint8')[_RGB][darkoak] *= self.darkoakLeafColor
-+ vertexArray.view('uint8')[_RGB][leaves] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][leaves], self.leafColor)
-+ vertexArray.view('uint8')[_RGB][pines] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][pines], self.pineLeafColor)
-+ vertexArray.view('uint8')[_RGB][birches] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][birches], self.birchLeafColor)
-+ vertexArray.view('uint8')[_RGB][jungle] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][jungle], self.jungleLeafColor)
-+ vertexArray.view('uint8')[_RGB][acacia] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][acacia], self.acaciaLeafColor)
-+ vertexArray.view('uint8')[_RGB][darkoak] = \
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][darkoak], self.darkoakLeafColor)
-
- yield
- arrays.append(vertexArray)
-@@ -1762,8 +1775,8 @@
- vertexArray.view('uint8')[_RGB] = 0xf # ignore precomputed directional light
- vertexArray.view('uint8')[_RGB] *= lights
- if colorize is not None:
-- vertexArray.view('uint8')[_RGB][colorize] *= LeafBlockRenderer.leafColor
-- vertexArray.view('uint8')[_RGB][colorize2] *= LeafBlockRenderer.leafColor
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][colorize], LeafBlockRenderer.leafColor)
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB][colorize2], LeafBlockRenderer.leafColor)
- arrays.append(vertexArray)
- yield
-
-@@ -1994,7 +2007,8 @@
- tex = texMap(railBlocks, bdata, pymclevel.faces.FaceYIncreasing)[:, numpy.newaxis, :]
-
- # disable 'powered' or 'pressed' bit for powered and detector rails
-- bdata[railBlocks != pymclevel.materials.alphaMaterials.Rail.ID] &= ~0x8
-+ bdata[railBlocks != pymclevel.materials.alphaMaterials.Rail.ID] = \
-+ numpy.uint8(bdata[railBlocks != pymclevel.materials.alphaMaterials.Rail.ID] & ~0x8)
-
- vertexArray = self.makeTemplate(direction, blockIndices)
- if not len(vertexArray):
-@@ -2853,7 +2867,7 @@
- lights = blockLight[blockIndices][..., numpy.newaxis, numpy.newaxis]
- vertexArray.view('uint8')[_RGB] *= lights
-
-- vertexArray.view('uint8')[_RGB] *= LeafBlockRenderer.leafColor
-+ numpy17_combine_colors(vertexArray.view('uint8')[_RGB], LeafBlockRenderer.leafColor)
-
- if direction == pymclevel.faces.FaceZIncreasing:
- vertexArray[_XYZ][..., 2] -= 0.0625
-
---- viewports/camera.py.orig 2015-08-12 07:12:26.000000000 -0600
-+++ viewports/camera.py 2015-12-24 18:32:08.063734146 -0700
-@@ -261,7 +261,7 @@
-
- def setModelview(self):
- pos = self.cameraPosition
-- look = numpy.array(self.cameraPosition)
-- look += self.cameraVector
-+ look = numpy.array(self.cameraPosition, dtype='f')
-+ look = look + self.cameraVector
- up = (0, 1, 0)
- GLU.gluLookAt(pos[0], pos[1], pos[2],
-
---- editortools/player.py.orig 2015-08-12 07:12:26.000000000 -0600
-+++ editortools/player.py 2015-12-24 19:17:01.763814413 -0700
-@@ -1025,7 +1025,7 @@
-
- pixelScale = 0.5 if self.editor.level.materials.name in ("Pocket", "Alpha") else 1.0
- texSize = 16 * pixelScale
-- cageTexVerts *= pixelScale
-+ cageTexVerts = cageTexVerts * pixelScale
-
- cageTexVerts = numpy.array(
- [((tx, ty), (tx + texSize, ty), (tx + texSize, ty + texSize), (tx, ty + texSize)) for (tx, ty) in