summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Nick Reimer2017-04-29 16:25:02 -0600
committerJeromy Nick Reimer2017-04-29 16:25:02 -0600
commitb0f27d3a45e50f2cbc8411620d090f17104670c6 (patch)
tree52f555242faecd62cf1cd9fb1f91ad221153802a
parent9544c0b12c578e3f7669835ad693ba32edae73bb (diff)
downloadaur-b0f27d3a45e50f2cbc8411620d090f17104670c6.tar.gz
Updated to 1.5.6.0
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD6
-rwxr-xr-xdirectories.patch22
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ea4f4ef521..292091ffdbb1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mcedit
pkgdesc = Minecraft world editor
- pkgver = 1.5.3.0
+ pkgver = 1.5.6.0
pkgrel = 1
url = https://github.com/mcedit/mcedit
arch = any
@@ -21,11 +21,11 @@ pkgbase = mcedit
source = MCEdit
source = MCEdit.desktop
source = directories.patch
- source = https://github.com/Khroki/MCEdit-Unified/archive/1.5.3.0.tar.gz
+ source = https://github.com/Khroki/MCEdit-Unified/archive/1.5.6.0.tar.gz
md5sums = b08f609c8923067b13a9bd462999a6f4
md5sums = 53fe3c41d58fd1f6429f90ba0b1831ac
- md5sums = 34f209ecd6f0898f91fb5ddce02a0c4c
- md5sums = 06055ce96c3091fd858eefde75228977
+ md5sums = 0c6d503c3a87cfb347564efd5b1b0fd5
+ md5sums = 8589c54a51b69e83ca6f36dd3db3be5f
pkgname = mcedit
diff --git a/PKGBUILD b/PKGBUILD
index 4b7962b069e1..4e68cc3e6a42 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='mcedit'
reponame='MCEdit-Unified'
-pkgver='1.5.3.0'
+pkgver='1.5.6.0'
pkgrel=1
pkgdesc='Minecraft world editor'
arch=('any')
@@ -70,5 +70,5 @@ package() {
md5sums=('b08f609c8923067b13a9bd462999a6f4'
'53fe3c41d58fd1f6429f90ba0b1831ac'
- '34f209ecd6f0898f91fb5ddce02a0c4c'
- '06055ce96c3091fd858eefde75228977')
+ '0c6d503c3a87cfb347564efd5b1b0fd5'
+ '8589c54a51b69e83ca6f36dd3db3be5f')
diff --git a/directories.patch b/directories.patch
index f0814b3c800e..2fabaca7c10e 100755
--- a/directories.patch
+++ b/directories.patch
@@ -39,14 +39,14 @@
logfile = os.path.join(os.getcwdu(), logfile)
fh = logging.FileHandler(logfile, mode="w")
---- splash.py.orig 2016-01-03 17:30:26.530655811 -0600
-+++ splash.py 2016-01-03 17:32:52.887326839 -0600
-@@ -26,7 +26,7 @@
- screen.blit(splash, (0, 0))
- except IOError:
- try:
-- font = pygame.font.Font(open(os.path.join(cur_dir, 'fonts', 'DejaVuSans-Bold.ttf'), 'rb'), 48)
-+ font = pygame.font.Font(open(os.path.join("/usr/share/fonts/TTF", 'DejaVuSans-Bold.ttf'), 'rb'), 48)
- buf = font.render("MCEDit is loading...", True, (128, 128, 128))
- screen = pygame.display.set_mode((buf.get_width() + 20, buf.get_height() + 20), pygame.NOFRAME)
- screen.blit(buf, (10, 10))
+--- pymclevel/materials.py.orig 2017-04-29 16:14:25.212312952 -0600
++++ pymclevel/materials.py 2017-04-29 16:14:32.882313180 -0600
+@@ -66,7 +66,7 @@
+ b.stringID = "air"
+ self.block_map[b.ID] = "minecraft:" + b.stringID
+
+- with open(os.path.join("pymclevel", definition_file)) as def_file:
++ with open(os.path.join("/usr/lib/mcedit/pymclevel", definition_file)) as def_file:
+ self.blockstates = json.load(def_file)
+
+ self.material_map[self._mats] = self