diff options
author | Nixuge | 2024-03-17 14:18:12 +0100 |
---|---|---|
committer | Nixuge | 2024-03-17 14:18:12 +0100 |
commit | 49a9387141f711034cb13dc8188535a6a99c99b6 (patch) | |
tree | ad9fb5b29f9626109ff26f6a026dc798583b7ca1 | |
parent | dfa1cc7afc9a282890b4fc9746df8a87057f9333 (diff) | |
download | aur-49a9387141f711034cb13dc8188535a6a99c99b6.tar.gz |
Handle PIP installation (rev 4)
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 11 | ||||
-rw-r--r-- | mcedit.install | 9 |
3 files changed, 12 insertions, 12 deletions
@@ -1,7 +1,7 @@ pkgbase = mcedit-unified-git pkgdesc = MCEdit is a versatile map utility, designed for editing Minecraft maps. pkgver = 1.6.0.0.r6.g90abfb17 - pkgrel = 3 + pkgrel = 4 url = http://podshot.github.io/MCEdit-Unified install = mcedit.install arch = x86_64 @@ -17,6 +17,6 @@ pkgbase = mcedit-unified-git sha256sums = SKIP sha256sums = e36c376ea3dd1c4d31a43ce7959a8ce5805804d7e9af92c143a14b4e4ae11b86 sha256sums = 541319e2b1aa7d26509b7b683a694340d8df48bbad5e1eb59d2934910aa65e47 - sha256sums = 00fdece371964410db21fbae225f8a74dd9daa22fdc468a38d7686985c525fd0 + sha256sums = 3ce7ee0f9da93f1f7a3c7137ffd4ab8dc5f1eff590514bac0a75f4a4beadc3e3 pkgname = mcedit-unified-git @@ -3,7 +3,7 @@ pkgname=mcedit-unified-git _pkgname=MCEdit-Unified pkgver=1.6.0.0.r6.g90abfb17 -pkgrel=3 +pkgrel=4 pkgdesc='MCEdit is a versatile map utility, designed for editing Minecraft maps.' url=http://podshot.github.io/MCEdit-Unified arch=(x86_64) @@ -14,7 +14,7 @@ install=mcedit.install conflicts=(mcedit) options=(!strip) source=("git+https://github.com/Podshot/MCEdit-Unified" "mcedit.desktop" "mcedit" "mcedit.install") -sha256sums=('SKIP' 'e36c376ea3dd1c4d31a43ce7959a8ce5805804d7e9af92c143a14b4e4ae11b86' '541319e2b1aa7d26509b7b683a694340d8df48bbad5e1eb59d2934910aa65e47' '00fdece371964410db21fbae225f8a74dd9daa22fdc468a38d7686985c525fd0') +sha256sums=('SKIP' 'e36c376ea3dd1c4d31a43ce7959a8ce5805804d7e9af92c143a14b4e4ae11b86' '541319e2b1aa7d26509b7b683a694340d8df48bbad5e1eb59d2934910aa65e47' '3ce7ee0f9da93f1f7a3c7137ffd4ab8dc5f1eff590514bac0a75f4a4beadc3e3') pkgver() { cd "${srcdir}/${_pkgname}" @@ -57,11 +57,4 @@ package() { # Executable install -dm755 "${pkgdir}/usr/bin" install -Dm755 "${srcdir}/mcedit" "${pkgdir}/usr/bin/mcedit" -} - -post_install() { - echo "Due to a problem with how venvs work, this package can only work if the venv is setup AFTER the pkgbuild (at least i think so)." - echo "It is recommended for you to run mcedit the first time through a terminal (using 'mcedit') to see the progress" - echo "After this, everything should work normally" - echo "If (by some miracle) mcedit unified updates, you can run 'mcedit --update' to try to install the dependencies & build again." }
\ No newline at end of file diff --git a/mcedit.install b/mcedit.install index 226291dd7598..eb6d2b904188 100644 --- a/mcedit.install +++ b/mcedit.install @@ -3,6 +3,7 @@ set -e if [ -n "$SUDO_USER" ]; then user=$SUDO_USER else + echo "USING ROOT USER. MAY CAUSE ISSUES IF THATS NOT YOUR PREFEERED USER." >&2 user=$(whoami) # fallback (if this is used it'll error out anyways) fi @@ -27,7 +28,13 @@ post_install() { # Install & setup the virtualenv su "$user" -c " - python2 -m pip install virtualenv + # If pip not found, install it + # Note: not using python2-pip because it seems to be having dependency problems. + if python2 -m pip install virtualenv 2>&1 | grep -q 'No module named pip'; then + curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py + python2 get-pip.py + python2 -m pip install virtualenv + fi python2 -m virtualenv venv " |