summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-06-29 11:57:39 -0400
committerAndrew Sun2020-06-29 11:57:39 -0400
commit2bdab2fd4871841eaf7c9fb543d5ceeb63086721 (patch)
treeb085d310633a88cc8cd185f44b3ac317fee26c7d
parent2a670278bfdf25b36e02070bb30eba527db1b225 (diff)
downloadaur-2bdab2fd4871841eaf7c9fb543d5ceeb63086721.tar.gz
0.4.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91ca52b7a1d9..ab5d6cb1c4a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mcfly
pkgdesc = Fly through your shell history
- pkgver = 0.3.6
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/cantino/mcfly
install = mcfly.install
@@ -10,8 +10,9 @@ pkgbase = mcfly
makedepends = rust
makedepends = cargo
depends = sh
- source = mcfly-0.3.6.tar.gz::https://github.com/cantino/mcfly/archive/v0.3.6.tar.gz
- sha256sums = 787f3db6cbfcfb74f3e33d22a2521ba95a3c949effc572bee5474c1327a3fe7a
+ optdepends = zsh: for zsh support
+ source = mcfly-0.4.0.tar.gz::https://github.com/cantino/mcfly/archive/v0.4.0.tar.gz
+ sha256sums = 233d33e2cde70f6bd76800becf7a718404e7ed19712bdee1d20b92a7486f6536
pkgname = mcfly
diff --git a/PKGBUILD b/PKGBUILD
index 6fb37a6681e2..704dd7aae525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Bruce Zhang <zttt183525594 at gmail dot com>
pkgname=mcfly
-pkgver=0.3.6
+pkgver=0.4.0
pkgrel=1
pkgdesc="Fly through your shell history"
arch=('i686' 'x86_64')
url="https://github.com/cantino/mcfly"
license=('MIT')
depends=('sh')
+optdepends=('zsh: for zsh support')
makedepends=('rust' 'cargo')
install=mcfly.install
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/cantino/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('787f3db6cbfcfb74f3e33d22a2521ba95a3c949effc572bee5474c1327a3fe7a')
+sha256sums=('233d33e2cde70f6bd76800becf7a718404e7ed19712bdee1d20b92a7486f6536')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -23,5 +24,6 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm755 "${srcdir}/${pkgname}-${pkgver}/target/release/mcfly" "${pkgdir}/usr/bin/mcfly"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/mcfly.bash" "${pkgdir}/usr/share/doc/mcfly/mcfly.bash"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/mcfly.zsh" "${pkgdir}/usr/share/doc/mcfly/mcfly.zsh"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}