summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoderkun2017-04-28 11:28:46 +0200
committercoderkun2017-04-28 11:28:46 +0200
commit431801e09edf0a0063df201b7c5c85e3420c7178 (patch)
tree90c20ea62f9f487484d00ef8e563ff8e3d1ff282
downloadaur-431801e09edf0a0063df201b7c5c85e3420c7178.tar.gz
Add package “mcg” version 1.0rc1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42145911da38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Apr 28 09:25:57 UTC 2017
+pkgbase = mcg
+ pkgdesc = A covergrid for the Music Player Daemon.
+ pkgver = 1.0rc1
+ pkgrel = 1
+ url = https://www.coderkun.de/codes/mcg
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python-gobject
+ depends = gtk3
+ depends = gsettings-desktop-schemas
+ depends = desktop-file-utils
+ optdepends = python-keyring
+ optdepends = avahi
+ provides = mcg
+ conflicts = mcg
+ source = mcg.tar.gz::https://github.com/coderkun/mcg/archive/v1.0rc1.tar.gz
+ sha256sums = 69556842d3fc84365c2d85188ee25f0b5c1aa3b9ee5f0ae5365a102930bbb468
+
+pkgname = mcg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3f7f0e52dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=mcg
+pkgver=1.0rc1
+pkgrel=1
+pkgdesc="A covergrid for the Music Player Daemon."
+url="https://www.coderkun.de/codes/mcg"
+arch=(any)
+license=(GPL)
+depends=('python-gobject' 'gtk3' 'gsettings-desktop-schemas' 'desktop-file-utils')
+optdepends=('python-keyring' 'avahi')
+makedepends=('python-setuptools' 'git')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("${pkgname}.tar.gz::https://github.com/coderkun/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('69556842d3fc84365c2d85188ee25f0b5c1aa3b9ee5f0ae5365a102930bbb468')
+
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py --no-compile-schemas build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py --no-compile-schemas \
+ install --root="$pkgdir/" --prefix=/usr --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}