summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Titmuss2015-11-25 16:21:45 +1100
committerAndrew Titmuss2015-11-25 16:21:45 +1100
commit0e16c0c8603343f0b2268e7907ad294fc27b01f1 (patch)
treeca306a09afaf9a7184d35c2b7eab9714bd3024c3
downloadaur-0e16c0c8603343f0b2268e7907ad294fc27b01f1.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a296ab1ef8fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mcinstall
+ pkgdesc = CLI Bash script to create a Minecraft server in one command
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/iandrewt/mcinstall
+ arch = x86_64
+ license = GPL
+ depends = bash
+ optdepends = java: if you want the server to use the already installed JRE instead of downloading one
+ source = mcinstall-1.0.3.tar.gz::https://github.com/iAndrewT/mcinstall/archive/1.0.3.tar.gz
+ md5sums = 56A52A9E54C2BEC71230D573439E6933
+
+pkgname = mcinstall
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af4d1485f4b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Andrew Titmuss <andrewctitmuss@outlook.com>
+pkgname=mcinstall
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="CLI Bash script to create a Minecraft server in one command"
+arch=('x86_64')
+url="https://github.com/iandrewt/mcinstall"
+license=('GPL')
+depends=('bash')
+optdepends=('java: if you want the server to use the already installed JRE instead of downloading one')
+source=($pkgname-$pkgver.tar.gz::https://github.com/iAndrewT/mcinstall/archive/$pkgver.tar.gz)
+md5sums=('56A52A9E54C2BEC71230D573439E6933')
+
+package() {
+ cd MCInstall-$pkgver
+ install -Dm755 "mcinstall" "$pkgdir/usr/bin/mcinstall"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}