summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordorianpb2020-04-02 17:28:43 -0400
committerdorianpb2020-04-02 17:28:43 -0400
commit53b607e9d8988a7eeb60f705d2508b926d8547a5 (patch)
tree4ffcd329344343d26e0a9b9a2fd626ed4b94d12b
downloadaur-53b607e9d8988a7eeb60f705d2508b926d8547a5.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rwxr-xr-xscript.sh14
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ba011397b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mcpelauncher-hx-script
+ pkgdesc = A script that downloads ChristopherHX's mcpelauncher fork. Doesn't check for updates, so just run it every once and a while.
+ pkgver = v1.0
+ pkgrel = 1
+ url = https://github.com/ChristopherHX/mcpelauncher-manifest
+ arch = any
+ license = GPL3
+ depends = git
+ depends = mcpelauncher-msa-git
+ depends = mcpelauncher-msa-ui-qt-git
+ source = script.sh
+ sha256sums = 1238a0a25160ca9816fdb1b46b35d4f30e1b25e5c9365efe02a2a7d61846f50f
+
+pkgname = mcpelauncher-hx-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4346026fe94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: dorianpb <dorian.peanut.butter@gmail.com>
+pkgname='mcpelauncher-hx-script'
+pkgver=v1.0
+pkgrel=1
+#epoch=
+pkgdesc="A script that downloads ChristopherHX's mcpelauncher fork. Doesn't check for updates, so just run it every once and a while."
+arch=('any')
+url="https://github.com/ChristopherHX/mcpelauncher-manifest"
+license=('GPL3')
+groups=()
+depends=('git' 'mcpelauncher-msa-git' 'mcpelauncher-msa-ui-qt-git')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+#install=
+#changelog=
+source=("script.sh")
+noextract=()
+sha256sums=('1238a0a25160ca9816fdb1b46b35d4f30e1b25e5c9365efe02a2a7d61846f50f')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 script.sh "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/script.sh b/script.sh
new file mode 100755
index 000000000000..496e2c5c2043
--- /dev/null
+++ b/script.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+mkdir -p /tmp/mcpelauncher-hx
+cd /tmp/mcpelauncher-hx
+for pkg in 'lib32-check' 'mcpelauncher-linux-git' 'mcpelauncher-ui-git'
+do
+ echo "====Downloading ${pkg}===="
+ git clone "https://github.com/ChristopherHX/"$pkg".git" $pkg
+ cd $pkg
+ git pull
+ echo "====Installing ${pkg}===="
+ makepkg --syncdeps --noconfirm --install --cleanbuild --needed
+ cd ../
+done
+rm -rf /tmp/mcpelauncher-hx