summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordorianpb2020-04-14 20:14:58 -0400
committerdorianpb2020-04-14 20:14:58 -0400
commit7737492865292b86ba03e7663f433a2b50a6f074 (patch)
tree32f6019b9e1ccdd2230ff9f2e71fb8c3f6f8e104
parent53b607e9d8988a7eeb60f705d2508b926d8547a5 (diff)
downloadaur-7737492865292b86ba03e7663f433a2b50a6f074.tar.gz
Changed to python, added another package from the AUR.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--script.py19
-rwxr-xr-xscript.sh16
4 files changed, 32 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ba011397b6..cc47ae5a9813 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,11 @@ pkgbase = mcpelauncher-hx-script
depends = git
depends = mcpelauncher-msa-git
depends = mcpelauncher-msa-ui-qt-git
+ depends = python
source = script.sh
- sha256sums = 1238a0a25160ca9816fdb1b46b35d4f30e1b25e5c9365efe02a2a7d61846f50f
+ source = script.py
+ sha256sums = bac567db8d71b9292c2b9c4b7acd416a2942c1958f638959d9d86a61816902ca
+ sha256sums = 200441f4095266168667ccc405760c9f5a7fb28d0db7f69698b34f2e54d760c0
pkgname = mcpelauncher-hx-script
diff --git a/PKGBUILD b/PKGBUILD
index e4346026fe94..2e013df14b67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: dorianpb <dorian.peanut.butter@gmail.com>
pkgname='mcpelauncher-hx-script'
-pkgver=v1.0
+pkgver=v1.1
pkgrel=1
#epoch=
pkgdesc="A script that downloads ChristopherHX's mcpelauncher fork. Doesn't check for updates, so just run it every once and a while."
@@ -8,7 +8,7 @@ arch=('any')
url="https://github.com/ChristopherHX/mcpelauncher-manifest"
license=('GPL3')
groups=()
-depends=('git' 'mcpelauncher-msa-git' 'mcpelauncher-msa-ui-qt-git')
+depends=('git' 'mcpelauncher-msa-git' 'mcpelauncher-msa-ui-qt-git' 'python')
makedepends=()
checkdepends=()
optdepends=()
@@ -19,9 +19,12 @@ backup=()
options=()
#install=
#changelog=
-source=("script.sh")
+source=("script.sh" "script.py")
noextract=()
-sha256sums=('1238a0a25160ca9816fdb1b46b35d4f30e1b25e5c9365efe02a2a7d61846f50f')
+sha256sums=(
+ 'bac567db8d71b9292c2b9c4b7acd416a2942c1958f638959d9d86a61816902ca'
+ '200441f4095266168667ccc405760c9f5a7fb28d0db7f69698b34f2e54d760c0'
+)
package() {
cd "${srcdir}"
diff --git a/script.py b/script.py
new file mode 100644
index 000000000000..2cb4dae110d6
--- /dev/null
+++ b/script.py
@@ -0,0 +1,19 @@
+import os
+pkglist = {
+ "https://aur.archlinux.org/":['lib32-check','lib32-libevdev'],
+ "https://github.com/ChristopherHX/":['mcpelauncher-linux-git','mcpelauncher-ui-git']
+ }
+os.system('mkdir -p /tmp/mcpelauncher-hx')
+os.chdir("/tmp/mcpelauncher-hx")
+for (url,pkgs) in pkglist.items():
+ for pkg in pkgs:
+ print("====Downloading "+pkg+"====")
+ os.system("git clone "+url+pkg+".git")
+for (url,pkgs) in pkglist.items():
+ for pkg in pkgs:
+ print("====Building "+pkg+"====")
+ os.chdir("/tmp/mcpelauncher-hx/"+pkg)
+ os.system("makepkg --syncdeps")
+ os.system("sudo pacman -U *.pkg.* --needed")
+ os.chdir("/tmp/mcpelauncher-hx")
+
diff --git a/script.sh b/script.sh
index 496e2c5c2043..e6132ea0ad4e 100755
--- a/script.sh
+++ b/script.sh
@@ -1,14 +1,2 @@
-#!/bin/sh
-mkdir -p /tmp/mcpelauncher-hx
-cd /tmp/mcpelauncher-hx
-for pkg in 'lib32-check' 'mcpelauncher-linux-git' 'mcpelauncher-ui-git'
-do
- echo "====Downloading ${pkg}===="
- git clone "https://github.com/ChristopherHX/"$pkg".git" $pkg
- cd $pkg
- git pull
- echo "====Installing ${pkg}===="
- makepkg --syncdeps --noconfirm --install --cleanbuild --needed
- cd ../
-done
-rm -rf /tmp/mcpelauncher-hx
+#!/bin/bash
+python ./script.py