summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2021-04-11 18:33:41 +0100
committerStephanie Wilde-Hobbs2021-04-11 18:33:41 +0100
commit7b821990bf695f1f228aae070bad6611a42c82a6 (patch)
tree9f038a9cfec985b42ebb4c36542117b3eb69560a
parent994f303b0a0d306544669c133565e12d031c7997 (diff)
downloadaur-7b821990bf695f1f228aae070bad6611a42c82a6.tar.gz
5.1.4-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ae57d798fcd..5a737724d1c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = mcstatus
pkgdesc = Provides an easy way to query Minecraft servers for any information they can expose.
- pkgver = 5.1.2
+ pkgver = 5.1.4
pkgrel = 1
url = https://github.com/Dinnerbone/mcstatus
arch = any
license = Apache
checkdepends = python-mock
- checkdepends = python-nose
+ checkdepends = python-pytest
+ checkdepends = python-pytest-asyncio
makedepends = python-setuptools
depends = python
depends = python-six
depends = python-click
depends = python-dnspython
depends = python-asyncio-dgram
- source = https://github.com/Dinnerbone/mcstatus/archive/release-5.1.2.tar.gz
- sha256sums = 096d95ef01cbbabc88ed9426a485ea4c66c41ce3d210c0d0d83bb3ac03102d37
+ source = https://github.com/Dinnerbone/mcstatus/archive/v5.1.4.tar.gz
+ sha256sums = b090b5bdef6ff5e4d0eb03bb4ea939c8a93224fe8642a3d5fcc7b50e7fdcad85
pkgname = mcstatus
diff --git a/PKGBUILD b/PKGBUILD
index 048408069fe2..1af4f43e0c3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephanie Wilde-Hobbs (RX14) <steph@rx14.co.uk>
pkgname=mcstatus
-pkgver=5.1.2
+pkgver=5.1.4
pkgrel=1
pkgdesc="Provides an easy way to query Minecraft servers for any information they can expose."
arch=(any)
@@ -9,31 +9,31 @@ url="https://github.com/Dinnerbone/mcstatus"
license=('Apache')
depends=(python python-six python-click python-dnspython python-asyncio-dgram)
makedepends=(python-setuptools)
-checkdepends=(python-mock python-nose)
-source=("https://github.com/Dinnerbone/mcstatus/archive/release-${pkgver}.tar.gz")
-sha256sums=('096d95ef01cbbabc88ed9426a485ea4c66c41ce3d210c0d0d83bb3ac03102d37')
+checkdepends=(python-mock python-pytest python-pytest-asyncio)
+source=("https://github.com/Dinnerbone/mcstatus/archive/v${pkgver}.tar.gz")
+sha256sums=('b090b5bdef6ff5e4d0eb03bb4ea939c8a93224fe8642a3d5fcc7b50e7fdcad85')
prepare() {
- cd "${srcdir}/mcstatus-release-${pkgver}"
+ cd "${srcdir}/mcstatus-${pkgver}"
sed -i 's/dnspython3/dnspython/' requirements.txt
}
build() {
- cd "${srcdir}/mcstatus-release-${pkgver}"
+ cd "${srcdir}/mcstatus-${pkgver}"
python setup.py build
}
check() {
- cd "${srcdir}/mcstatus-release-${pkgver}"
+ cd "${srcdir}/mcstatus-${pkgver}"
- nosetests
+ python -m pytest
}
package() {
- cd "${srcdir}/mcstatus-release-${pkgver}"
+ cd "${srcdir}/mcstatus-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}