summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-05-26 18:41:55 +0200
committerNicolas Iooss2018-05-26 18:41:55 +0200
commit26fbd481c6540e08422f7d731598057b7f1d497d (patch)
tree5d9c827a3f6d3add367293d88eb28522470e7fff
parenta5bbdf2d1af8fbe9828c6756e06629ac7882635c (diff)
downloadaur-26fbd481c6540e08422f7d731598057b7f1d497d.tar.gz
mcstrans 2.8-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56f99bd152e..6ad58999d787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mcstrans
pkgdesc = SELinux MCS translation daemon
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -8,10 +8,10 @@ pkgbase = mcstrans
groups = selinux
license = GPL2
depends = libcap
- depends = libselinux>=2.7
+ depends = libselinux>=2.8
depends = pcre
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/mcstrans-2.7.tar.gz
- sha256sums = cdca003282d160b50ad695ab5b013c05ca21387a419b2f89288534184d16e1e2
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/mcstrans-2.8.tar.gz
+ sha256sums = ec6ea65660550ed6bbd2a834725ba7526ac53599753d7b95072e4afd4afc14e4
pkgname = mcstrans
diff --git a/PKGBUILD b/PKGBUILD
index 953a49212a05..a4f4deb0906e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=mcstrans
-pkgver=2.7
+pkgver=2.8
pkgrel=1
pkgdesc="SELinux MCS translation daemon"
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/selinux/wiki'
license=('GPL2')
groups=('selinux')
-depends=('libcap' 'libselinux>=2.7' 'pcre')
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('cdca003282d160b50ad695ab5b013c05ca21387a419b2f89288534184d16e1e2')
+depends=('libcap' 'libselinux>=2.8' 'pcre')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('ec6ea65660550ed6bbd2a834725ba7526ac53599753d7b95072e4afd4afc14e4')
build() {
cd "${pkgname}-${pkgver}"
-
make
}
package() {
cd "${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- install
+ make DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
# Remove mcstrans init script
rm -rf "${pkgdir}/etc/rc.d"