summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 13:56:39 +0200
committerNicolas Iooss2017-08-11 13:56:39 +0200
commita5bbdf2d1af8fbe9828c6756e06629ac7882635c (patch)
tree2d1acbe94864960bafbfedbbe30f176a852da244
downloadaur-a5bbdf2d1af8fbe9828c6756e06629ac7882635c.tar.gz
Create mcstrans package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b56f99bd152e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mcstrans
+ pkgdesc = SELinux MCS translation daemon
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux/wiki
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL2
+ depends = libcap
+ depends = libselinux>=2.7
+ depends = pcre
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/mcstrans-2.7.tar.gz
+ sha256sums = cdca003282d160b50ad695ab5b013c05ca21387a419b2f89288534184d16e1e2
+
+pkgname = mcstrans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..953a49212a05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=mcstrans
+pkgver=2.7
+pkgrel=1
+pkgdesc="SELinux MCS translation daemon"
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+groups=('selinux')
+depends=('libcap' 'libselinux>=2.7' 'pcre')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('cdca003282d160b50ad695ab5b013c05ca21387a419b2f89288534184d16e1e2')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" \
+ LIBSEPOLA=/usr/lib/libsepol.a \
+ SBINDIR="${pkgdir}/usr/bin" \
+ install
+
+ # Remove mcstrans init script
+ rm -rf "${pkgdir}/etc/rc.d"
+ rmdir "${pkgdir}/etc"
+}