summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManish Munikar2016-06-01 08:52:11 +0545
committerManish Munikar2016-06-01 08:52:11 +0545
commite226c520045587de360c89c2a64f7f4f9fbb624d (patch)
tree7eb4ca08e251c00b27bf3def6c1e8276fe36008b
downloadaur-e226c520045587de360c89c2a64f7f4f9fbb624d.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cbd51c387f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Wed Jun 1 03:06:25 UTC 2016
+pkgbase = mcu8051ide
+ pkgdesc = Graphical IDE for MCS-51 based microcontrollers
+ pkgver = 1.4.10
+ pkgrel = 1
+ url = http://www.moravia-microsystems.com/mcu8051ide
+ arch = any
+ license = GPLv3
+ depends = tcl>=8.5.9
+ depends = tk>=8.5.9
+ depends = tcllib>=1.6
+ depends = bwidget>=1.8
+ depends = itcl3>=3.4
+ depends = tdom>=0.8
+ depends = tkimg>=1.3
+ depends = tclx>=8.4
+ optdepends = cmake: cross-platform make system
+ optdepends = rxvt-unicode: for unicode support
+ optdepends = vim: for text-editing
+ optdepends = emacs: for text-editing
+ optdepends = nano: for text-editing
+ optdepends = le: for text-editing
+ optdepends = hunspell: for spell-checking
+ source = mcu8051ide-1.4.10.rpm::http://www.moravia-microsystems.com/download/mcu8051ide/mcu8051ide/1.4.10/mcu8051ide-1.4-11.noarch.rpm
+ md5sums = a3b136c26d699a6c9a8c6e9e6a66d316
+
+pkgname = mcu8051ide
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed0b20644a7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Manish Munikar <munikarmanish@gmail.com>
+
+pkgname=mcu8051ide
+pkgver=1.4.10
+pkgrel=1
+epoch=
+pkgdesc="Graphical IDE for MCS-51 based microcontrollers"
+arch=('any')
+url="http://www.moravia-microsystems.com/mcu8051ide"
+license=('GPLv3')
+groups=()
+depends=('tcl>=8.5.9'
+ 'tk>=8.5.9'
+ 'tcllib>=1.6'
+ 'bwidget>=1.8'
+ 'itcl3>=3.4'
+ 'tdom>=0.8'
+ 'tkimg>=1.3'
+ 'tclx>=8.4')
+makedepends=()
+checkdepends=()
+optdepends=('cmake: cross-platform make system'
+ 'rxvt-unicode: for unicode support'
+ 'vim: for text-editing'
+ 'emacs: for text-editing'
+ 'nano: for text-editing'
+ 'le: for text-editing'
+ 'hunspell: for spell-checking')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}-${pkgver}.rpm::http://www.moravia-microsystems.com/download/mcu8051ide/mcu8051ide/1.4.10/mcu8051ide-1.4-11.noarch.rpm")
+noextract=()
+md5sums=('a3b136c26d699a6c9a8c6e9e6a66d316')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ cp -r ${srcdir}/usr ${pkgdir}/usr
+}