summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-30 13:56:42 +0100
committerJoan Bruguera2019-03-30 13:56:42 +0100
commit0e98fed1d366cb5c7cec134f7776fceea222e92e (patch)
tree6474a1910cdcea2925e32bd8f07e10fdc38ce0d9
downloadaur-0e98fed1d366cb5c7cec134f7776fceea222e92e.tar.gz
Initial version.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ce77dc157aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mcxx
+ pkgdesc = Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://pm.bsc.es/ompss
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc7
+ depends = nanox
+ depends = python2
+ depends = gcc-fortran
+ depends = gperf
+ depends = git
+ depends = sqlite3
+ source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
+ sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+
+pkgname = mcxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b72d45fb96b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname='mcxx'
+_bundlepkgname='ompss'
+pkgdesc='Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.'
+pkgver='2.1.0'
+_bundlepkgver='17.12.1'
+pkgrel='1'
+arch=('i686' 'x86_64')
+url='https://pm.bsc.es/ompss'
+license=('GPL3')
+depends=(nanox python2 gcc-fortran gperf git sqlite3)
+makedepends=(gcc7)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
+sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344)
+
+# WORKAROUND: The sources are outdated compared to Arch's environment,
+# so we have to downgrade/disable some things...
+export CC=gcc-7
+export CXX=g++-7
+[[ ! -z "$LDFLAGS" ]] && export LDFLAGS="$LDFLAGS,--no-as-needed"
+
+build() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ # See https://hub.docker.com/r/bscpm/ompss/dockerfile
+ ./configure \
+ --prefix=/usr \
+ --enable-ompss \
+ --with-nanox=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}