summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-30 14:34:02 +0100
committerJoan Bruguera2019-03-30 14:34:02 +0100
commit5359d3dba5dc732ba8eaf0a6724f77f5bd15d6fe (patch)
treeb254781edcf185c8a864245dfcb8f41e8e444ec6
parent2f0e90037496fcb3f3cd6bd55fcaa5fc589e6c68 (diff)
downloadaur-5359d3dba5dc732ba8eaf0a6724f77f5bd15d6fe.tar.gz
Fix build-gperf files.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56d4e585b620..fc64836ed7e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mcxx
pkgdesc = Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.
pkgver = 2.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b7003ec6a3c8..94ce6c2f3f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _bundlepkgname='ompss'
pkgdesc='Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.'
pkgver='2.1.0'
_bundlepkgver='17.12.1'
-pkgrel='2'
+pkgrel='3'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL3')
@@ -19,6 +19,18 @@ export CC=gcc-7
export CXX=g++-7
[[ ! -z "$LDFLAGS" ]] && export LDFLAGS="$LDFLAGS,--no-as-needed"
+prepare() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ # WORKAROUND: Force gperf files to be regenerated, to avoid build errors
+ # (declaration mismatches due to unsigned int / gperf_length_t)
+ rm src/driver/cxx-configoptions.c
+ rm src/driver/cxx-debugflags.c
+ rm src/driver/cxx-fileextensions.c
+ rm src/frontend/cxx-asttype-str-internal.h
+ rm src/frontend/fortran/fortran03-keywords.c
+}
+
build() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"