summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-04-01 12:55:13 +0200
committerJoan Bruguera2019-04-01 13:14:34 +0200
commit7ee3c12edb1d5d4874d90c2e6cb065193266a971 (patch)
tree2adc83bb5a078180fca58374ab9918e957aff7e7
parentd5dc4e904e566529fa186c5c68a14ebd7d87c06e (diff)
downloadaur-7ee3c12edb1d5d4874d90c2e6cb065193266a971.tar.gz
Add patches to build on GCC8.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8eb6dc8496bf..0cee4d911ad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = mcxx
pkgdesc = Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.
pkgver = 2.1.0
- pkgrel = 4
+ pkgrel = 5
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
license = GPL3
- makedepends = gcc7
depends = nanox
depends = python2
depends = gcc-fortran
@@ -15,9 +14,11 @@ pkgbase = mcxx
source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
source = https://github.com/bsc-pm/mcxx/commit/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch
source = https://github.com/bsc-pm/mcxx/commit/0f2c80f40f1e452fd450aef20838667eef801475.patch
+ source = https://github.com/bsc-pm/mcxx/commit/862ad57617772802ad6a804a1f5ecf470ca00ddc.patch
sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
sha512sums = 1de58ecc762c8e6d79e9daf0718a5f1bd96c929effa6962ddd411dc0794061d6d35fc520f2889588b33d5edbdf70c9d0ac5d3800fa669f09a031ec3e55ef5eb6
sha512sums = c2fd4647a96de3287d1b15d2ab31d99dfa73c12e7e74a77b4ca6857e7106a0431462055feb570436a4957883bd085a2f0199f046b53a682b984b38862eaa1491
+ sha512sums = ef42c42495717a0c06e6fedf17e2c02904b20f59fd19f114a6d407913f924c340ebbec721252048c394a705bae39234e8c9346e584317ef6356111ae149724c3
pkgname = mcxx
diff --git a/PKGBUILD b/PKGBUILD
index b1658117fbf8..35d133c3bbe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,22 @@ _bundlepkgname='ompss'
pkgdesc='Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.'
pkgver='2.1.0'
_bundlepkgver='17.12.1'
-pkgrel='4'
+pkgrel='5'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL3')
depends=(nanox python2 gcc-fortran gperf sqlite3)
-makedepends=(gcc7)
source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
"https://github.com/bsc-pm/mcxx/commit/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch"
- "https://github.com/bsc-pm/mcxx/commit/0f2c80f40f1e452fd450aef20838667eef801475.patch")
+ "https://github.com/bsc-pm/mcxx/commit/0f2c80f40f1e452fd450aef20838667eef801475.patch"
+ "https://github.com/bsc-pm/mcxx/commit/862ad57617772802ad6a804a1f5ecf470ca00ddc.patch")
sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
1de58ecc762c8e6d79e9daf0718a5f1bd96c929effa6962ddd411dc0794061d6d35fc520f2889588b33d5edbdf70c9d0ac5d3800fa669f09a031ec3e55ef5eb6
- c2fd4647a96de3287d1b15d2ab31d99dfa73c12e7e74a77b4ca6857e7106a0431462055feb570436a4957883bd085a2f0199f046b53a682b984b38862eaa1491)
+ c2fd4647a96de3287d1b15d2ab31d99dfa73c12e7e74a77b4ca6857e7106a0431462055feb570436a4957883bd085a2f0199f046b53a682b984b38862eaa1491
+ ef42c42495717a0c06e6fedf17e2c02904b20f59fd19f114a6d407913f924c340ebbec721252048c394a705bae39234e8c9346e584317ef6356111ae149724c3)
# WORKAROUND: The sources are outdated compared to Arch's environment,
# so we have to downgrade/disable some things...
-export CC=gcc-7
-export CXX=g++-7
[[ ! -z "$LDFLAGS" ]] && export LDFLAGS="$LDFLAGS,--no-as-needed"
prepare() {
@@ -40,6 +39,9 @@ prepare() {
# https://github.com/bsc-pm/ompss-ee
patch -p1 < "$srcdir/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch"
patch -p1 < "$srcdir/0f2c80f40f1e452fd450aef20838667eef801475.patch"
+
+ # WORKAROUND: Needed to build in GCC8 (but was unnecessary in GCC7)
+ patch -p1 < "$srcdir/862ad57617772802ad6a804a1f5ecf470ca00ddc.patch"
}
build() {