summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-10 21:09:10 +0100
committerJoan Bruguera2019-12-10 21:09:10 +0100
commitaa6ba0e4309233fa5ce6062203888a1610cfa1cd (patch)
treefb1682ea3ce6b88854c197c6ff98577ba0d02111
parentd5ab0a1d3b51760220107b533394db45dd460a53 (diff)
downloadaur-aa6ba0e4309233fa5ce6062203888a1610cfa1cd.tar.gz
Upgrade tracking to the latest version. Additionally, change BSC package versioning numbers, in order to include the year in the pkgver. This is to deal with the fact that multiple, different tallbars are routinely released for the same version number. Up until now, this was handled by bumping pkgrel, but this is not the correct way to handle this, since it's not just a rebuild, but just the upstream code changed.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e3fc63b617..019211064c29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mcxx
pkgdesc = Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.
- pkgver = 2.3.0
+ pkgver = 2.3.0.20190627
pkgrel = 1
url = https://pm.bsc.es/ompss
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0b515e3dc78a..2d9c1b9f09a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='mcxx'
_bundlepkgname='ompss'
pkgdesc='Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.'
-pkgver='2.3.0'
+pkgver='2.3.0.20190627'
_bundlepkgver='19.06'
pkgrel='1'
arch=('i686' 'x86_64')
@@ -18,11 +18,11 @@ sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c
[[ ! -z "$LDFLAGS" ]] && export LDFLAGS="$LDFLAGS,--no-as-needed"
prepare() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
}
build() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
# WORKAROUND: Force gperf files to be regenerated, to avoid build errors
# (declaration mismatches due to unsigned int / gperf_length_t)
@@ -42,7 +42,7 @@ build() {
}
package() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
}