summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-31 14:42:52 +0200
committerJoan Bruguera2019-03-31 14:42:52 +0200
commitd5dc4e904e566529fa186c5c68a14ebd7d87c06e (patch)
treef99425d1dbbea4b9ef105286c016b4f94f737ab1
parent5359d3dba5dc732ba8eaf0a6724f77f5bd15d6fe (diff)
downloadaur-d5dc4e904e566529fa186c5c68a14ebd7d87c06e.tar.gz
Fix _Float128 problems when including standard C math headers.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc64836ed7e5..8eb6dc8496bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mcxx
pkgdesc = Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.
pkgver = 2.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
@@ -13,7 +13,11 @@ pkgbase = mcxx
depends = gperf
depends = sqlite3
source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
+ source = https://github.com/bsc-pm/mcxx/commit/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch
+ source = https://github.com/bsc-pm/mcxx/commit/0f2c80f40f1e452fd450aef20838667eef801475.patch
sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+ sha512sums = 1de58ecc762c8e6d79e9daf0718a5f1bd96c929effa6962ddd411dc0794061d6d35fc520f2889588b33d5edbdf70c9d0ac5d3800fa669f09a031ec3e55ef5eb6
+ sha512sums = c2fd4647a96de3287d1b15d2ab31d99dfa73c12e7e74a77b4ca6857e7106a0431462055feb570436a4957883bd085a2f0199f046b53a682b984b38862eaa1491
pkgname = mcxx
diff --git a/PKGBUILD b/PKGBUILD
index 94ce6c2f3f80..b1658117fbf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,18 @@ _bundlepkgname='ompss'
pkgdesc='Mercurium is a C/C++/Fortran source-to-source compilation infrastructure aimed at fast prototyping developed by the Programming Models group at the Barcelona Supercomputing Center.'
pkgver='2.1.0'
_bundlepkgver='17.12.1'
-pkgrel='3'
+pkgrel='4'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL3')
depends=(nanox python2 gcc-fortran gperf sqlite3)
makedepends=(gcc7)
-source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
-sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
+ "https://github.com/bsc-pm/mcxx/commit/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch"
+ "https://github.com/bsc-pm/mcxx/commit/0f2c80f40f1e452fd450aef20838667eef801475.patch")
+sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+ 1de58ecc762c8e6d79e9daf0718a5f1bd96c929effa6962ddd411dc0794061d6d35fc520f2889588b33d5edbdf70c9d0ac5d3800fa669f09a031ec3e55ef5eb6
+ c2fd4647a96de3287d1b15d2ab31d99dfa73c12e7e74a77b4ca6857e7106a0431462055feb570436a4957883bd085a2f0199f046b53a682b984b38862eaa1491)
# WORKAROUND: The sources are outdated compared to Arch's environment,
# so we have to downgrade/disable some things...
@@ -29,6 +33,13 @@ prepare() {
rm src/driver/cxx-fileextensions.c
rm src/frontend/cxx-asttype-str-internal.h
rm src/frontend/fortran/fortran03-keywords.c
+
+ # WORKAROUND: Those patches are necessary to avoid a _float128 / _Float128 clash
+ # (due to Arch being more cutting-edge than usual)
+ # You can test this by building examples in (e.g. 02-beginners/matmul):
+ # https://github.com/bsc-pm/ompss-ee
+ patch -p1 < "$srcdir/26fb7dffbaa06a5389acb1138717b14ce7d350a1.patch"
+ patch -p1 < "$srcdir/0f2c80f40f1e452fd450aef20838667eef801475.patch"
}
build() {