summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-17 12:37:08 -0400
committerChris Severance2015-08-17 12:37:08 -0400
commit1616fbf7407e9740acd1691d7858bb85fab00a14 (patch)
treeec0524266f9080dd9f93e9740a568da9222e4d90
parent7fc3ce0298e76c4e555ad75b0cd7efa3319affc1 (diff)
downloadaur-1616fbf7407e9740acd1691d7858bb85fab00a14.tar.gz
Better compile flags from AUR wiggle
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9abaa2ca5817..e5f4c0ebb21a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,9 @@ makedepends=('git')
depends=('glibc')
#optdepends=('lvm2' 'dm-crypt' 'bcache')
backup=("etc/${_pkgname}.conf")
+_verurl='ftp://ftp.kernel.org/pub/linux/utils/raid/mdadm/'
+_versed='mdadm-\(.*\)\.tar\.xz'
+_veropt='f'
_archlink="@@@::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/@@@?h=packages/${_pkgname}"
source=(# use either one, but not both. Reset with makepkg -sCf. My comparison shows these are identical, including the tags. Github is faster.
#"mdadm_gitnb::git://neil.brown.name/${_pkgname}"
@@ -31,7 +34,6 @@ source=(# use either one, but not both. Reset with makepkg -sCf. My comparison s
"mdadm_udev_hook")
install="${_pkgname}.install"
replaces=('raidtools')
-
sha256sums=('SKIP'
'4ce1e90690282f98e4828e11576fbd61be65e97a2cdae6c7eac7035ea5ee53e5'
'd297b4fa6213016ec08e4f66d07cf7eb03426e4e17ab31eddfa5c5c1d82ea294'
@@ -56,16 +58,18 @@ prepare() {
build() {
set -u
cd mdadm_git*/
- make -s -j $(nproc) CXFLAGS='-O' BINDIR='/usr/bin' UDEVDIR='/usr/lib/udev'
+ msg2 'Build mdadm'
+ make -s -j $(nproc) CXFLAGS="${CFLAGS}" BINDIR='/usr/bin' UDEVDIR='/usr/lib/udev'
# build static mdassemble for Arch's initramfs for use with mkinitcpio hook mdadm. Hook mdadm_udev does not use mdassemble.
- make -s -j $(nproc) CXFLAGS='-O' MDASSEMBLE_AUTO=1 mdassemble
+ msg2 'Build mdassemble'
+ make -s -j $(nproc) CXFLAGS="${CFLAGS}" MDASSEMBLE_AUTO=1 mdassemble
set +u
}
check() {
set -u
cd mdadm_git*/
- make -s -j $(nproc) CXFLAGS='-O' test
+ make -s -j $(nproc) CXFLAGS="${CFLAGS}" test
#sudo ./test # can't do sudo in a PKGBUILD
set +u
}