summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-05-11 19:34:43 +0200
committerEric Engestrom2020-05-11 19:34:43 +0200
commit3dcd337b4791701854c800076b5d2f1ef02c6fdd (patch)
treedb64e76cd0e99bb16e8edd8edaa570374afd1a1a
downloadaur-3dcd337b4791701854c800076b5d2f1ef02c6fdd.tar.gz
initial commit - v0.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0329b9351a9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mdbook-epub
+ pkgdesc = MDBook EPUB Backend
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/Michael-F-Bryan/mdbook-epub
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ source = https://github.com/Michael-F-Bryan/mdbook-epub/archive/v0.3.0.tar.gz
+ sha256sums = 1dfa8a58e969d975d365d32dec4ebbfbb066e55c58c3f329d59f96c8bae121f4
+
+pkgname = mdbook-epub
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa52d1a042cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=mdbook-epub
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="MDBook EPUB Backend"
+url="https://github.com/Michael-F-Bryan/mdbook-epub"
+arch=(x86_64)
+license=(MIT)
+makedepends=(rust cargo)
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('1dfa8a58e969d975d365d32dec4ebbfbb066e55c58c3f329d59f96c8bae121f4')
+
+build() {
+ cd mdbook-epub-$pkgver
+ cargo build --release
+}
+
+package() {
+ cd mdbook-epub-$pkgver
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}