summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2019-12-20 09:17:54 +1100
committerWesley Moore2019-12-20 09:17:54 +1100
commit43dc98226a4add381ea35b2f1800caf81959d09b (patch)
tree3ce05fc1308efac2171aad7cab70db01d4a92464
parent330dd2c8eb84b125d05d948a778387537722f09e (diff)
downloadaur-43dc98226a4add381ea35b2f1800caf81959d09b.tar.gz
Version 0.14.0
Remove LTO patch as this is now upstream.
-rw-r--r--.SRCINFO10
-rw-r--r--Cargo.toml.patch9
-rw-r--r--PKGBUILD25
3 files changed, 11 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 162f260efaa0..e40d08ee58b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mdcat
pkgdesc = Show CommonMark (a standardized Markdown dialect) documents on text terminals.
- pkgver = 0.13.0
- pkgrel = 3
+ pkgver = 0.14.0
+ pkgrel = 1
url = https://github.com/lunaryorn/mdcat
arch = i686
arch = x86_64
@@ -11,10 +11,8 @@ pkgbase = mdcat
makedepends = git
depends = oniguruma
conflicts = mdcat-git
- source = mdcat-0.13.0.tar.gz::https://github.com/lunaryorn/mdcat/archive/mdcat-0.13.0.tar.gz
- source = Cargo.toml.patch
- sha256sums = 9528a0dedcb9db559c9973001787f474f87559366a2c7a2ff01148c5ab31eac1
- sha256sums = 7860347baf642380ce26366c94ecff6e31a6b9ee4521740d130e87350dac148d
+ source = mdcat-0.14.0.tar.gz::https://github.com/lunaryorn/mdcat/archive/mdcat-0.14.0.tar.gz
+ sha256sums = 330059534642bba502e82d6a86f16451b7ce9d2ad02e356fd0bcff961020bc9f
pkgname = mdcat
diff --git a/Cargo.toml.patch b/Cargo.toml.patch
deleted file mode 100644
index 20a2a6e2d744..000000000000
--- a/Cargo.toml.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- mdcat-mdcat-0.13.0.orig/Cargo.toml 2019-03-31 05:38:16.000000000 +1100
-+++ mdcat-mdcat-0.13.0/Cargo.toml 2019-03-31 09:38:17.614741379 +1100
-@@ -76,3 +76,6 @@
- tag-message = "mdcat {{version}}"
- tag-prefix = "mdcat-"
- pre-release-hook = "./scripts/prerelease-hook.py"
-+
-+[profile.release]
-+lto = true
diff --git a/PKGBUILD b/PKGBUILD
index d6794ff6bb48..9206e3e73d46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=mdcat
-pkgver=0.13.0
-pkgrel=3
+pkgver=0.14.0
+pkgrel=1
pkgdesc='Show CommonMark (a standardized Markdown dialect) documents on text terminals.'
arch=('i686' 'x86_64')
url="https://github.com/lunaryorn/mdcat"
@@ -9,32 +9,21 @@ license=('Apache')
depends=('oniguruma')
conflicts=('mdcat-git')
makedepends=('rust' 'cargo' 'git')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgname-$pkgver.tar.gz"
- Cargo.toml.patch)
-sha256sums=('9528a0dedcb9db559c9973001787f474f87559366a2c7a2ff01148c5ab31eac1'
- '7860347baf642380ce26366c94ecff6e31a6b9ee4521740d130e87350dac148d')
-
-prepare() {
- # Enable LTO
- cd "$pkgname-$pkgname-$pkgver"
- patch -p1 < ../Cargo.toml.patch
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgname-$pkgver.tar.gz")
+sha256sums=('330059534642bba502e82d6a86f16451b7ce9d2ad02e356fd0bcff961020bc9f')
build() {
cd "$pkgname-$pkgname-$pkgver"
- # Default features are iterm2 terminology and remote_resources. iterm2 is
- # unecessary on Arch, remote_resources brings in a chain of depenedencies
- # reqwest->native-tls->openssl. The version of the openssl crate that is
- # selected does not recognise the version that Arch is using and results in
- # the build failing so this feature is disabled.
+ # Default features include remote_resources. remote_resources brings in a
+ # larege dependency chain reqwest->native-tls->openssl.
#
# We dynamically link against the system libonig so that, that dependency is
# shared with, and kept up to date with the rest of the system. It means
# this package will need to have the pkgrel bumped if there is a breaking
# release to libonig though.
RUSTONIG_DYNAMIC_LIBONIG=1 RUSTONIG_SYSTEM_LIBONIG=1 cargo build \
- --release --no-default-features --features terminology
+ --release --no-default-features --locked
}
package() {