summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2019-12-23 15:16:16 +1100
committerWesley Moore2019-12-23 15:16:16 +1100
commit93b84a2ce3300e8d22e17430bd2d3acd51261c67 (patch)
tree7d15d891584a1043d0ba34d0e4a9d93ffa2429e6
parent43dc98226a4add381ea35b2f1800caf81959d09b (diff)
downloadaur-93b84a2ce3300e8d22e17430bd2d3acd51261c67.tar.gz
Enable remote_resources per maintainer request
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40d08ee58b5..50b4cf22cba2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mdcat
pkgdesc = Show CommonMark (a standardized Markdown dialect) documents on text terminals.
pkgver = 0.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lunaryorn/mdcat
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = mdcat
makedepends = cargo
makedepends = git
depends = oniguruma
+ depends = openssl
conflicts = mdcat-git
source = mdcat-0.14.0.tar.gz::https://github.com/lunaryorn/mdcat/archive/mdcat-0.14.0.tar.gz
sha256sums = 330059534642bba502e82d6a86f16451b7ce9d2ad02e356fd0bcff961020bc9f
diff --git a/PKGBUILD b/PKGBUILD
index 9206e3e73d46..c4edd66a915d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=mdcat
pkgver=0.14.0
-pkgrel=1
+pkgrel=2
pkgdesc='Show CommonMark (a standardized Markdown dialect) documents on text terminals.'
arch=('i686' 'x86_64')
url="https://github.com/lunaryorn/mdcat"
license=('Apache')
-depends=('oniguruma')
+depends=('oniguruma' 'openssl')
conflicts=('mdcat-git')
makedepends=('rust' 'cargo' 'git')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgname-$pkgver.tar.gz")
@@ -15,15 +15,12 @@ sha256sums=('330059534642bba502e82d6a86f16451b7ce9d2ad02e356fd0bcff961020bc9f')
build() {
cd "$pkgname-$pkgname-$pkgver"
- # Default features include remote_resources. remote_resources brings in a
- # larege dependency chain reqwest->native-tls->openssl.
- #
# We dynamically link against the system libonig so that, that dependency is
# shared with, and kept up to date with the rest of the system. It means
# this package will need to have the pkgrel bumped if there is a breaking
# release to libonig though.
RUSTONIG_DYNAMIC_LIBONIG=1 RUSTONIG_SYSTEM_LIBONIG=1 cargo build \
- --release --no-default-features --locked
+ --release --locked
}
package() {