summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2020-04-12 09:57:10 +1000
committerWesley Moore2020-04-12 09:57:10 +1000
commitc3632a87ad5389d590c5b4022669ca8370c0e515 (patch)
tree8725bd8975fbcbe7181901a785077c226d8c3cc0
parent7fbb258c95a0df19297a9f67f8f33d6781092dce (diff)
downloadaur-c3632a87ad5389d590c5b4022669ca8370c0e515.tar.gz
Version 0.16.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cef9d58b3fd6..feecbccfc284 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = mdcat
- pkgdesc = Show CommonMark (a standardized Markdown dialect) documents on text terminals.
- pkgver = 0.15.1
+ pkgdesc = Sophisticated Markdown rendering for the terminal
+ pkgver = 0.16.0
pkgrel = 1
url = https://github.com/lunaryorn/mdcat
arch = i686
arch = x86_64
license = Apache
- makedepends = rust
makedepends = cargo
- makedepends = git
- depends = oniguruma
depends = openssl
conflicts = mdcat-git
- source = mdcat-0.15.1.tar.gz::https://github.com/lunaryorn/mdcat/archive/mdcat-0.15.1.tar.gz
- sha256sums = 564d1b4afd44ed2e4d8095f95f5a49c08c321cd4074417b500076c966248aeea
+ source = mdcat-0.16.0.tar.gz::https://github.com/lunaryorn/mdcat/archive/mdcat-0.16.0.tar.gz
+ sha256sums = 32dd1332d547f18bfb7d295dff957997464df6e62a3fbe97468332e742ceb5bc
pkgname = mdcat
diff --git a/PKGBUILD b/PKGBUILD
index 971f239b51f6..d8b2b525ac2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=mdcat
-pkgver=0.15.1
+pkgver=0.16.0
pkgrel=1
-pkgdesc='Show CommonMark (a standardized Markdown dialect) documents on text terminals.'
+pkgdesc='Sophisticated Markdown rendering for the terminal'
arch=('i686' 'x86_64')
url="https://github.com/lunaryorn/mdcat"
license=('Apache')
-depends=('oniguruma' 'openssl')
+depends=('openssl')
conflicts=('mdcat-git')
-makedepends=('rust' 'cargo' 'git')
+makedepends=('cargo')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgname-$pkgver.tar.gz")
-sha256sums=('564d1b4afd44ed2e4d8095f95f5a49c08c321cd4074417b500076c966248aeea')
+sha256sums=('32dd1332d547f18bfb7d295dff957997464df6e62a3fbe97468332e742ceb5bc')
build() {
cd "$pkgname-$pkgname-$pkgver"
-
- # We dynamically link against the system libonig so that, that dependency is
- # shared with, and kept up to date with the rest of the system. It means
- # this package will need to have the pkgrel bumped if there is a breaking
- # release to libonig though.
- RUSTONIG_DYNAMIC_LIBONIG=1 RUSTONIG_SYSTEM_LIBONIG=1 cargo build \
- --release --locked
+ cargo build --release --locked
}
package() {
- install -Dm755 "$srcdir/$pkgname-$pkgname-$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd "$pkgname-$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
}