summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChau Duong2023-10-05 10:24:41 +0700
committerChau Duong2023-10-05 10:24:41 +0700
commit251565930abd032de565bedeec3dd49b388bef25 (patch)
treed7982df7079a30ea9c9b947bd717fdc1c595e74f
downloadaur-251565930abd032de565bedeec3dd49b388bef25.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a22a380c571
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mdformat-tables-git
+ pkgver = v0.4.1.r0.c169887
+ pkgrel = 1
+ url = https://github.com/executablebooks/mdformat-tables
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-flit
+ makedepends = python-installer
+ makedepends = python-poetry
+ depends = mdformat
+ provides = mdformat-tables
+ conflicts = mdformat-tables
+ source = mdformat-tables::git+https://github.com/executablebooks/mdformat-tables.git
+ sha256sums = SKIP
+
+pkgname = mdformat-tables-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..298c36148c39
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.*
+mdformat-tables/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19e378a04772
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chau Duong <duongdominhchau@gmail.com>
+_pkgname=mdformat-tables
+pkgname="${_pkgname}-git"
+pkgver=v0.4.1.r0.c169887
+pkgrel=1
+pkgdesc=""
+arch=(any)
+url="https://github.com/executablebooks/mdformat-tables"
+license=('MIT')
+depends=(mdformat)
+makedepends=(
+ python-pip
+ python-build
+ python-wheel
+ python-flit
+ python-installer
+ python-poetry
+)
+source=("${_pkgname}::git+${url}.git")
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$_pkgname"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}