summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-07-18 19:46:47 +0200
committerbegin-theadventure2023-07-18 19:46:47 +0200
commitd344e4abf16084978a961db6487d4f3ff2002ec0 (patch)
tree8504fc13110d773bd087a4696e746331cd2d5bc7
parent974221cbacf8009d669bbfc0b31f986cdd27b243 (diff)
downloadaur-d344e4abf16084978a961db6487d4f3ff2002ec0.tar.gz
Edit source and desktop creation
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76243104f375..2e38fa24c9c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mdlshit-bin
pkgdesc = source engine .mdl v49 -> v53 converter (binary release)
pkgver = 2.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/headassbtw/mdlshit
arch = x86_64
license = GPL2
makedepends = imagemagick
provides = mdlshit
conflicts = mdlshit
- source = https://github.com/headassbtw/mdlshit/releases/download/2.3.2/mdlshit_linux_x64.tar.gz
- source = https://raw.githubusercontent.com/headassbtw/mdlshit/c5f2c6c3cb259e051a42b76cbeb2fa501cda2af9/product.ico
- source = https://raw.githubusercontent.com/headassbtw/mdlshit/c5f2c6c3cb259e051a42b76cbeb2fa501cda2af9/README.md
- source = https://raw.githubusercontent.com/headassbtw/mdlshit/c5f2c6c3cb259e051a42b76cbeb2fa501cda2af9/LICENSE
+ source = mdlshit-2.3.2.tar.gz::https://github.com/headassbtw/mdlshit/releases/download/2.3.2/mdlshit_linux_x64.tar.gz
+ source = https://raw.githubusercontent.com/headassbtw/mdlshit/2.3.2/product.ico
+ source = https://raw.githubusercontent.com/headassbtw/mdlshit/2.3.2/README.md
+ source = https://raw.githubusercontent.com/headassbtw/mdlshit/2.3.2/LICENSE
sha256sums = b01aa6f2d2f96982399faff8f177a96df3538ce75771aa9445c03b519cb8ecb0
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 33cf433d7237..7b51f90c2b40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mdlshit
pkgname=$_pkgname-bin
pkgver=2.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="source engine .mdl v49 -> v53 converter (binary release)"
arch=('x86_64')
url="https://github.com/headassbtw/mdlshit"
@@ -11,12 +11,10 @@ license=('GPL2')
makedepends=('imagemagick')
conflicts=($_pkgname)
provides=($_pkgname)
-_desktop=$_pkgname.desktop
-_url2=https://raw.githubusercontent.com/headassbtw/mdlshit/c5f2c6c3cb259e051a42b76cbeb2fa501cda2af9
-source=("$url/releases/download/$pkgver/${_pkgname}_linux_x64.tar.gz"
- "$_url2/product.ico"
- "$_url2/README.md"
- "$_url2/LICENSE")
+source=("$_pkgname-$pkgver.tar.gz::$url/releases/download/$pkgver/${_pkgname}_linux_x64.tar.gz"
+ "https://raw.githubusercontent.com/headassbtw/mdlshit/$pkgver/product.ico"
+ "https://raw.githubusercontent.com/headassbtw/mdlshit/$pkgver/README.md"
+ "https://raw.githubusercontent.com/headassbtw/mdlshit/$pkgver/LICENSE")
sha256sums=('b01aa6f2d2f96982399faff8f177a96df3538ce75771aa9445c03b519cb8ecb0'
'SKIP'
'SKIP'
@@ -24,24 +22,23 @@ sha256sums=('b01aa6f2d2f96982399faff8f177a96df3538ce75771aa9445c03b519cb8ecb0'
prepare() {
# "Create a shortcut"
- echo "Categories=Game;" >> $_desktop
- sed -i '1 i\Comment=source engine .mdl v49 -> v53 converter ' $_desktop
- sed -i '1 i\StartupWMClass=mdlshit' $_desktop
- sed -i '1 i\Icon=mdlshit' $_desktop
- sed -i '1 i\Type=Application' $_desktop
- sed -i '1 i\Terminal=false' $_desktop
- sed -i '1 i\Exec=mdlshit %U' $_desktop
- sed -i '1 i\Name=mdlshit' $_desktop
- sed -i '1 i\[Desktop Entry]' $_desktop
- mkdir -p desktop
- mv $_desktop desktop
+ echo "Categories=Game;" >> desktop
+ sed -i '1 i\Comment=source engine .mdl v49 -> v53 converter' desktop
+ sed -i '1 i\StartupWMClass=mdlshit' desktop
+ sed -i '1 i\Icon=mdlshit' desktop
+ sed -i '1 i\Type=Application' desktop
+ sed -i '1 i\Terminal=false' desktop
+ sed -i '1 i\Exec=mdlshit %U' desktop
+ sed -i '1 i\Name=mdlshit' desktop
+ sed -i '1 i\[Desktop Entry]' desktop
+ mv desktop $pkgname.desktop
convert product.ico $_pkgname.png
}
package() {
install -Dm644 $_pkgname.png -t "$pkgdir/usr/share/pixmaps"
- install -Dm644 desktop/$_desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 $pkgname.desktop -t "$pkgdir/usr/share/applications"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm755 $_pkgname -t "$pkgdir/usr/bin"