summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2015-06-08 20:28:12 +0300
committerMatti Niemenmaa2015-07-14 16:18:58 +0300
commit0ac829836861ade4b8f9c51c8aa898bcf82ada4f (patch)
tree24ac7303ee81023fa6713a5315742918e6ba7a99
parent06f5e75d8fbd744ac3d7c02a3e3697faeeb58071 (diff)
downloadaur-0ac829836861ade4b8f9c51c8aa898bcf82ada4f.tar.gz
Use libc instead of libiconv
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--makefile.patch21
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3b902d26e1f..294b6f58feec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,14 +7,13 @@ pkgbase = mdxplay-git
arch = x86_64
license = GPL2
makedepends = git
- depends = libiconv
depends = sdl
provides = mdxplay
conflicts = mdxplay
source = mdxplay-git::git+https://github.com/BouKiCHi/mdxplayer.git
source = makefile.patch
sha256sums = SKIP
- sha256sums = edf0e80f51b0840f95e121f784b8ffb95fafbaa2afaa35038dae26b94e397e29
+ sha256sums = 65459a3a37cf3fd493da9b79e0848d9fcc6a5d39db383f80a52f510011b56e77
pkgname = mdxplay-git
diff --git a/PKGBUILD b/PKGBUILD
index 0c0073e43ebe..1b09b5a25ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@ pkgdesc='Command line music player for Sharp X68000 MDX files'
arch=(i686 x86_64)
url='https://github.com/BouKiCHi/mdxplayer/tree/master/jni/mdxmini'
license=(GPL2)
-depends=(libiconv sdl)
+depends=(sdl)
makedepends=(git)
provides=(mdxplay)
conflicts=(mdxplay)
source=("$pkgname"::'git+https://github.com/BouKiCHi/mdxplayer.git'
makefile.patch)
sha256sums=('SKIP'
- 'edf0e80f51b0840f95e121f784b8ffb95fafbaa2afaa35038dae26b94e397e29')
+ '65459a3a37cf3fd493da9b79e0848d9fcc6a5d39db383f80a52f510011b56e77')
pkgver() {
cd "$srcdir/$pkgname"
diff --git a/makefile.patch b/makefile.patch
index 220430a8b96d..f77c445f671f 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,13 +1,14 @@
diff --git i/jni/mdxmini/mak/general.mak w/jni/mdxmini/mak/general.mak
-index e56323b..8f01823 100644
+index e56323b..fff9e7c 100644
--- i/jni/mdxmini/mak/general.mak
+++ w/jni/mdxmini/mak/general.mak
-@@ -5,7 +5,7 @@
- CC = gcc
- LD = gcc
- AR = ar
--LIBS =
-+LIBS = -lm
- SLIBS =
- LFLAGS =
-
+@@ -19,8 +19,7 @@ endif
+
+ # iconv
+ ifneq ($(OS),Windows_NT)
+-CFLAGS += -DUSE_ICONV
+-LIBS += -liconv
++LIBS += -lm
+ endif
+
+ #