summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Fox2019-06-23 01:12:24 -0500
committerBailey Fox2019-06-23 01:12:24 -0500
commit122b4d1d57cc2715419171d8998a4895c681e647 (patch)
treed67c0e1a42f008c95d39af02c3a4f72fc86fca71
parentf851c29f9e650a93371e0a66d3a86ab740ffc9d3 (diff)
downloadaur-122b4d1d57cc2715419171d8998a4895c681e647.tar.gz
Remove unused dependencies, fix version, correct db-location patch; Thanks to egrupled
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--db-location.patch13
3 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a142c61fa57..96891e3e2fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meanalyzer-git
pkgdesc = Intel Management Engine firmware analysis tool
- pkgver = r155.r0.g51b7a16
+ pkgver = 1.86.0.r166.r0.g36d1698
pkgrel = 1
url = https://github.com/platomav/MEAnalyzer
arch = any
@@ -8,8 +8,6 @@ pkgbase = meanalyzer-git
makedepends = dos2unix
makedepends = git
depends = python-colorama
- depends = python-prettytable
- depends = python-huffman11-git
depends = python-crccheck
source = meanalyzer-git::git+https://github.com/platomav/MEAnalyzer#branch=master
source = db-location.patch
@@ -17,7 +15,7 @@ pkgbase = meanalyzer-git
source = https://github.com/platomav/PTable/archive/boxchar.zip
sha256sums = SKIP
sha256sums = d6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7
- sha256sums = da169c2384682e5c0b4634ed8d8d1a589ae099d73aa97e95f1c8a63fe2c7c1c9
+ sha256sums = 23a9cd5ece78ba32f18fac8698330e444d3c194db042345611b166a28502fb98
sha256sums = d8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4
pkgname = meanalyzer-git
diff --git a/PKGBUILD b/PKGBUILD
index a0a59ffbd64a..d5a8a67d1b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
pkgname=meanalyzer-git
-pkgver=r155.r0.g51b7a16
+pkgver=1.86.0.r166.r0.g36d1698
pkgrel=1
pkgdesc='Intel Management Engine firmware analysis tool'
arch=('any')
url='https://github.com/platomav/MEAnalyzer'
-branch='master'
+_branch='master'
license=('GPL3')
-depends=('python-colorama' 'python-prettytable' 'python-huffman11-git' 'python-crccheck')
+depends=('python-colorama' 'python-crccheck')
makedepends=('dos2unix' 'git')
-source=("${pkgname}::git+${url}#branch=${branch}"
+source=("${pkgname}::git+${url}#branch=${_branch}"
'db-location.patch'
- 'change-mea_dir.patch'
- 'https://github.com/platomav/PTable/archive/boxchar.zip')
+ 'change-mea_dir.patch'
+ 'https://github.com/platomav/PTable/archive/boxchar.zip')
sha256sums=('SKIP'
'd6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7'
- 'da169c2384682e5c0b4634ed8d8d1a589ae099d73aa97e95f1c8a63fe2c7c1c9'
+ '23a9cd5ece78ba32f18fac8698330e444d3c194db042345611b166a28502fb98'
'd8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4')
pkgver() {
@@ -35,8 +35,9 @@ prepare() {
package() {
cd "${srcdir}/PTable-boxchar"
python setup.py install --root="$pkgdir/" --optimize=1
-
+
cd "${srcdir}/${pkgname}"
install -Dm644 MEA.dat "${pkgdir}"/usr/lib/meanalyzer/MEA.dat
+ install -Dm644 Huffman.dat "${pkgdir}"/usr/lib/meanalyzer/Huffman.dat
install -Dm755 MEA.py "${pkgdir}"/usr/bin/meanalyzer
}
diff --git a/db-location.patch b/db-location.patch
index fc224851618c..88bb672ab8da 100644
--- a/db-location.patch
+++ b/db-location.patch
@@ -1,11 +1,20 @@
--- MEA.py
+++ MEA.py
+@@ -6236,7 +6236,7 @@
+ HUFFMAN_SYMBOLS = {}
+ HUFFMAN_UNKNOWNS = {}
+ mapping_types = {'code' : 0x20, 'data' : 0x60}
+- huffman_dict = os.path.join(mea_dir, 'Huffman.dat')
++ huffman_dict = '/usr/lib/meanalyzer/Huffman.dat'
+
+ # Check if Huffman dictionary version is supported
+ if (cse_variant, cse_major) in [('CSME', 11), ('CSSPS', 4)] : dict_version = 11
@@ -7110,7 +7110,7 @@
arg_num = len(sys.argv)
-
+
# Set dependencies paths
-db_path = os.path.join(mea_dir, 'MEA.dat')
+db_path = '/usr/lib/meanalyzer/MEA.dat'
-
+
# Check if dependencies exist
depend_db = os.path.isfile(db_path)