summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Fox2019-06-23 01:25:05 -0500
committerBailey Fox2019-06-23 01:25:05 -0500
commit6adb7f32cbd627911551bebaa8871825ffce4947 (patch)
tree0c4850b5dc1dff0728e131399af5a491749e5670
parent122b4d1d57cc2715419171d8998a4895c681e647 (diff)
downloadaur-6adb7f32cbd627911551bebaa8871825ffce4947.tar.gz
Fix hashing error, correct db-location patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--db-location.patch26
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96891e3e2fa5..3c6c3c35cc2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meanalyzer-git
pkgdesc = Intel Management Engine firmware analysis tool
pkgver = 1.86.0.r166.r0.g36d1698
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/platomav/MEAnalyzer
arch = any
license = GPL3
@@ -14,8 +14,8 @@ pkgbase = meanalyzer-git
source = change-mea_dir.patch
source = https://github.com/platomav/PTable/archive/boxchar.zip
sha256sums = SKIP
- sha256sums = d6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7
- sha256sums = 23a9cd5ece78ba32f18fac8698330e444d3c194db042345611b166a28502fb98
+ sha256sums = 5cadc65438f96ddd3be6e9ef8e5e61904cce093331c2e140a7f1ad635e259481
+ sha256sums = da169c2384682e5c0b4634ed8d8d1a589ae099d73aa97e95f1c8a63fe2c7c1c9
sha256sums = d8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4
pkgname = meanalyzer-git
diff --git a/PKGBUILD b/PKGBUILD
index d5a8a67d1b7e..3a26194174bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=meanalyzer-git
pkgver=1.86.0.r166.r0.g36d1698
-pkgrel=1
+pkgrel=2
pkgdesc='Intel Management Engine firmware analysis tool'
arch=('any')
url='https://github.com/platomav/MEAnalyzer'
@@ -16,8 +16,8 @@ source=("${pkgname}::git+${url}#branch=${_branch}"
'change-mea_dir.patch'
'https://github.com/platomav/PTable/archive/boxchar.zip')
sha256sums=('SKIP'
- 'd6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7'
- '23a9cd5ece78ba32f18fac8698330e444d3c194db042345611b166a28502fb98'
+ '5cadc65438f96ddd3be6e9ef8e5e61904cce093331c2e140a7f1ad635e259481'
+ 'da169c2384682e5c0b4634ed8d8d1a589ae099d73aa97e95f1c8a63fe2c7c1c9'
'd8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4')
pkgver() {
diff --git a/db-location.patch b/db-location.patch
index 88bb672ab8da..d5c024c31b88 100644
--- a/db-location.patch
+++ b/db-location.patch
@@ -1,20 +1,20 @@
---- MEA.py
-+++ MEA.py
+--- MEA.py 2019-06-23 01:19:51.808627020 -0500
++++ MEA.py 2019-06-23 01:19:19.000000000 -0500
@@ -6236,7 +6236,7 @@
- HUFFMAN_SYMBOLS = {}
- HUFFMAN_UNKNOWNS = {}
- mapping_types = {'code' : 0x20, 'data' : 0x60}
-- huffman_dict = os.path.join(mea_dir, 'Huffman.dat')
-+ huffman_dict = '/usr/lib/meanalyzer/Huffman.dat'
-
- # Check if Huffman dictionary version is supported
- if (cse_variant, cse_major) in [('CSME', 11), ('CSSPS', 4)] : dict_version = 11
-@@ -7110,7 +7110,7 @@
+ HUFFMAN_SYMBOLS = {}
+ HUFFMAN_UNKNOWNS = {}
+ mapping_types = {'code' : 0x20, 'data' : 0x60}
+- huffman_dict = os.path.join(mea_dir, 'Huffman.dat')
++ huffman_dict = '/usr/lib/meanalyzer/Huffman.dat'
+
+ # Check if Huffman dictionary version is supported
+ if (cse_variant, cse_major) in [('CSME', 11), ('CSSPS', 4)] : dict_version = 11
+@@ -7195,7 +7195,7 @@
arg_num = len(sys.argv)
-
+
# Set dependencies paths
-db_path = os.path.join(mea_dir, 'MEA.dat')
+db_path = '/usr/lib/meanalyzer/MEA.dat'
-
+
# Check if dependencies exist
depend_db = os.path.isfile(db_path)