summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Goethel2015-06-08 22:21:40 +0200
committerOliver Goethel2015-06-08 22:21:40 +0200
commit1a8425d9aed9549ad6de41c2f6a61849e4112e37 (patch)
tree1064d4de512fc8a4f2f7bdb6215eff56a143e105
downloadaur-1a8425d9aed9549ad6de41c2f6a61849e4112e37.tar.gz
Initial import to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD58
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b42460fdd52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = med
+ pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5
+ pkgver = 3.0.8
+ pkgrel = 2
+ url = http://www.code-aster.org/outils/med/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-fortran
+ makedepends = coreutils
+ depends = hdf5
+ optdepends = tk
+ optdepends = python2
+ conflicts = med_fichier
+ replaces = med_fichier
+ source = http://files.salome-platform.org/Salome/other/med-3.0.8.tar.gz
+ md5sums = 8adb41767474d262abca1ce031d08f47
+
+pkgname = med
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab7a4579a663
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer Oliver Goethel <deezy>
+# Contributor: Michele Mocciola <mickele>
+# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
+# Contributor: Philippe Miron <tuxication@gmail.com>
+# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
+# Modified by: Martin Ortbauer <mortbauer@gmail.com>
+
+pkgname=med
+pkgver=3.0.8
+pkgrel=2
+pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5"
+url="http://www.code-aster.org/outils/med/"
+license=('LGPL')
+depends=('hdf5')
+makedepends=('gcc-fortran' 'coreutils')
+optdepends=('tk' 'python2')
+provides=()
+conflicts=('med_fichier')
+replaces=('med_fichier')
+backup=()
+arch=('i686' 'x86_64')
+source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz")
+md5sums=('8adb41767474d262abca1ce031d08f47')
+
+build() {
+ if [ "$CARCH" = "x86_64" ]; then
+ export FFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
+ export FCFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
+ export CPPFLAGS="-DHAVE_F77INT64 ${CPPFLAGS}"
+ export F77=gfortran
+ export FC=gfortran
+ else # i686
+ export FFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
+ export FCFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
+ export F77=gfortran
+ export FC=gfortran
+ fi
+
+ export PYTHON="python2"
+
+ cd ${srcdir}/${pkgname}-${pkgver} || return 1
+
+ ./configure --with-f90=gfortran --prefix=/usr --datadir=/usr/share/med || return 1
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver} || return 1
+
+ make DESTDIR=${pkgdir} install || return 1
+ # now move the testprograms to share, we don't want all the stuff in the bindir
+ cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testc ${pkgdir}/usr/share/med/testc
+ cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testf ${pkgdir}/usr/share/med/
+ cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/unittests ${pkgdir}/usr/share/med/
+ cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/usescases ${pkgdir}/usr/share/med/
+ rm -r ${pkgdir}/usr/bin/{usescases,unittests,testf,testc}
+}
+