summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Goethel2016-05-05 21:08:12 +0200
committerOliver Goethel2016-05-05 21:08:12 +0200
commit63154b0989db7d8579546511798252815f02abc1 (patch)
tree4a9524b9be460d6fdfbb1894060294a1f5e925eb
parent19d6146eb9de96b82d35d81dcb1d1236c5e2c8be (diff)
downloadaur-63154b0989db7d8579546511798252815f02abc1.tar.gz
upgpkg: med-3.1.0-2
added patches for rebuild with hdf5-1.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--patch-include_2.3.6_med.h.in14
-rw-r--r--patch-include_med.h.in15
-rw-r--r--patch-src_2.3.6_ci_MEDequivInfo.c11
5 files changed, 62 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84787ad511b..5dcb70851f22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jan 5 16:18:26 UTC 2016
+# Thu May 5 19:06:50 UTC 2016
pkgbase = med
pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.code-aster.org/outils/med/
arch = i686
arch = x86_64
@@ -18,7 +18,13 @@ pkgbase = med
conflicts = med_fichier
replaces = med_fichier
source = http://files.salome-platform.org/Salome/other/med-3.1.0.tar.gz
+ source = patch-include_2.3.6_med.h.in
+ source = patch-include_med.h.in
+ source = patch-src_2.3.6_ci_MEDequivInfo.c
md5sums = a1e1eb068f20634f5ea797914241eb51
+ md5sums = b83949326d7ae0ca77a06822b754a329
+ md5sums = 14a151cea108388d7a3b4c62887169f6
+ md5sums = 8f0cbf6f08783a6ba68ff5ab240dd62e
pkgname = med
diff --git a/PKGBUILD b/PKGBUILD
index 537012211359..ba3f90301def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=med
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5"
url="http://www.code-aster.org/outils/med/"
license=('LGPL')
@@ -19,8 +19,14 @@ conflicts=('med_fichier')
replaces=('med_fichier')
backup=()
arch=('i686' 'x86_64')
-source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz")
-md5sums=('a1e1eb068f20634f5ea797914241eb51')
+source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz"
+ "patch-include_2.3.6_med.h.in"
+ "patch-include_med.h.in"
+ "patch-src_2.3.6_ci_MEDequivInfo.c")
+md5sums=('a1e1eb068f20634f5ea797914241eb51'
+ 'b83949326d7ae0ca77a06822b754a329'
+ '14a151cea108388d7a3b4c62887169f6'
+ '8f0cbf6f08783a6ba68ff5ab240dd62e')
build() {
if [ "$CARCH" = "x86_64" ]; then
@@ -42,6 +48,11 @@ build() {
# patch H5public_extract.h.in
sed -i -e '/^#typedef/ s/#/\/\//' ./include/H5public_extract.h.in
+
+ #patch for hdf5-1.10
+ patch -p0 < ${srcdir}/patch-include_2.3.6_med.h.in
+ patch -p0 < ${srcdir}/patch-include_med.h.in
+ patch -p0 < ${srcdir}/patch-src_2.3.6_ci_MEDequivInfo.c
./configure --with-f90=mpif90 --prefix=/usr --datadir=/usr/share/med --with-swig=yes || return 1
make || return 1
diff --git a/patch-include_2.3.6_med.h.in b/patch-include_2.3.6_med.h.in
new file mode 100644
index 000000000000..2602df9f7b9d
--- /dev/null
+++ b/patch-include_2.3.6_med.h.in
@@ -0,0 +1,14 @@
+--- include/2.3.6/med.h.in.orig 2014-10-09 08:12:57 UTC
++++ include/2.3.6/med.h.in
+@@ -25,11 +25,7 @@ extern "C" {
+ #endif
+
+ #define HDF5_VERSION (H5_VERS_MAJOR * 10000 + H5_VERS_MINOR * 100 + H5_VERS_RELEASE )
+-#if HDF5_VERSION < 10607
+-#define HDF5_SELECT_BUG (const hsize_t **)
+-#else
+ #define HDF5_SELECT_BUG
+-#endif
+
+
+ #define MED_NUM_MAJEUR 2
diff --git a/patch-include_med.h.in b/patch-include_med.h.in
new file mode 100644
index 000000000000..c47a57c26967
--- /dev/null
+++ b/patch-include_med.h.in
@@ -0,0 +1,15 @@
+--- include/med.h.in.orig 2014-10-09 08:12:57 UTC
++++ include/med.h.in
+@@ -27,12 +27,7 @@ extern "C" {
+
+ #define HDF5_VERSION (H5_VERS_MAJOR * 10000 + H5_VERS_MINOR * 100 + H5_VERS_RELEASE )
+
+-#if HDF5_VERSION < 10607
+-/*TODO : A enlever après MAJ complète api hdf5-1.8 */
+-#define HDF5_SELECT_BUG (const hsize_t **)
+-#else
+ #define HDF5_SELECT_BUG
+-#endif
+
+ /*Le symbole H5F_LIBVER_18 n'existe pas dans hdf5-1.8.4 (uniquement à partir de la version 1.8.6)
+ Pour rester dans le modèle interne hdf introduit en 1.8 quelque soit les futurs modèles internes hdf
diff --git a/patch-src_2.3.6_ci_MEDequivInfo.c b/patch-src_2.3.6_ci_MEDequivInfo.c
new file mode 100644
index 000000000000..12006a1f3227
--- /dev/null
+++ b/patch-src_2.3.6_ci_MEDequivInfo.c
@@ -0,0 +1,11 @@
+--- src/2.3.6/ci/MEDequivInfo.c.orig 2014-10-09 08:12:59 UTC
++++ src/2.3.6/ci/MEDequivInfo.c
+@@ -24,7 +24,7 @@
+ #include <stdlib.h>
+
+ int
+-MEDequivInfo(int fid, char *maa, int ind, char *eq, char *des)
++MEDequivInfo(med_idt fid, char *maa, int ind, char *eq, char *des)
+ {
+ med_idt eqid;
+ med_err ret;