summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-07-23 16:04:10 +0200
committerGuilhem Saurel2019-07-23 16:04:10 +0200
commitbf35efd6af1c3e1b9a6c02f97f99a19f9e5905fa (patch)
tree78416206ade5d43a3a857adb02b807e716c2c43c
parent24f1ed2fabb9d69378c74e73ede08b6d0e6799b1 (diff)
downloadaur-bf35efd6af1c3e1b9a6c02f97f99a19f9e5905fa.tar.gz
update to 4.0.0, and follow med
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD75
2 files changed, 54 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ff2849babfc..54e5ca677332 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
-# Generated by mksrcinfo v8
-# Sun May 8 17:13:41 UTC 2016
pkgbase = med-openmpi
- pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5
- pkgver = 3.1.0
- pkgrel = 2
- url = http://www.code-aster.org/outils/med/
- arch = i686
+ pkgdesc = Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://www.salome-platform.org/downloads
arch = x86_64
license = LGPL
makedepends = gcc-fortran
- makedepends = coreutils
- makedepends = openmpi
makedepends = swig
+ makedepends = openmpi
+ makedepends = cmake
depends = hdf5-openmpi
- depends = zlib
+ depends = tk
+ depends = python
provides = med
conflicts = med
replaces = med
- source = http://files.salome-platform.org/Salome/other/med-3.1.0.tar.gz
- source = h5public_extract.patch
- source = signature_conflict_fix.patch
- md5sums = a1e1eb068f20634f5ea797914241eb51
- md5sums = 156ab9456bab7b70237d0fc785b97e7c
- md5sums = 1e9f5c1ff2ecc08d8179178eebe03882
+ source = http://files.salome-platform.org/Salome/other/med-4.0.0.tar.gz
+ sha256sums = a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004
pkgname = med-openmpi
+pkgname = med-openmpi-docs
+ arch = any
+ depends =
+
diff --git a/PKGBUILD b/PKGBUILD
index ed19794c0729..11019b3fd0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,56 @@
-# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Maintainer: nim65s
+# Former Maintainer: Joey Dumont <joey.dumont@gmail.com>
# Contributor: simonp
# Contributor: Martin Ortbauer <mortbauer@gmail.com>
# Original: Michele Mocciola <mickele>
# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
-pkgname=med-openmpi
-pkgver=3.1.0
-pkgrel=2
-pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5"
-url="http://www.code-aster.org/outils/med/"
-license=("LGPL")
-depends=('hdf5-openmpi' 'zlib')
-makedepends=('gcc-fortran' 'coreutils' 'openmpi' 'swig')
+_pkgname='med'
+pkgname=('med-openmpi' 'med-openmpi-docs')
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5"
+url="https://www.salome-platform.org/downloads"
+license=('LGPL')
+depends=('hdf5-openmpi' 'tk' 'python')
+makedepends=('gcc-fortran' 'swig' 'openmpi' 'cmake')
provides=('med')
+arch=('x86_64')
conflicts=('med')
replaces=('med')
-arch=('i686' 'x86_64')
-source=("http://files.salome-platform.org/Salome/other/${pkgname//-openmpi/}-${pkgver}.tar.gz"
- "h5public_extract.patch"
- "signature_conflict_fix.patch")
-md5sums=('a1e1eb068f20634f5ea797914241eb51'
- '156ab9456bab7b70237d0fc785b97e7c'
- '1e9f5c1ff2ecc08d8179178eebe03882')
-
-prepare() {
- cd ${srcdir}/${pkgname//-openmpi/}-${pkgver}_SRC || return 1
- patch -Np1 -i ../h5public_extract.patch
- patch -Np1 -i ../signature_conflict_fix.patch
-}
+source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004')
build() {
- cd ${srcdir}/${pkgname//-openmpi/}-${pkgver}_SRC || return 1
-
- PYTHON=/usr/bin/python2 MPIFC=mpif90 ./configure --prefix=/usr --with-swig=swig --datadir=/usr/share/med --with-med_int=int || return 1
- make || return 1
+ cd ${_pkgname}-${pkgver}
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMEDFILE_USE_MPI=ON -DMEDFILE_BUILD_PYTHON=ON .
+ make
}
-package() {
- cd ${srcdir}/${pkgname//-openmpi/}-${pkgver}_SRC || return 1
+# I got 37 tests failed out of 91…
+#check() {
+ #cd "$pkgname-$pkgver"
+ #make test
+#}
+
+package_med-openmpi() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
- make DESTDIR=${pkgdir} install || return 1
- # now move the testprograms to share, we don't want all the stuff in the bindir
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testc ${pkgdir}/usr/share/med/testc
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testf ${pkgdir}/usr/share/med/
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/unittests ${pkgdir}/usr/share/med/
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/usescases ${pkgdir}/usr/share/med/
- rm -r ${pkgdir}/usr/bin/{usescases,unittests,testf,testc}
+ rm -rf $pkgdir/usr/share/doc
}
+package_med-openmpi-docs() {
+ arch=('any')
+ depends=()
+
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+
+ rm -rf $pkgdir/usr/share/cmake
+ rm -rf $pkgdir/usr/lib
+ rm -rf $pkgdir/usr/include
+ rm -rf $pkgdir/usr/bin
+}