summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-11-19 23:30:59 +0100
committerGabriel Souza Franco2018-11-19 23:30:59 +0100
commit66df2776c277a4e1f3fc7f464c1fd6eb06bb66fe (patch)
treebabc0605da2e77d7140e0de26e72627db018f484
parent246fab1b0b029a22c5bc8daac4334db6ccd17f29 (diff)
downloadaur-med-salome.tar.gz
Update to version 3.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD113
3 files changed, 35 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08854325ff76..05c2cb2f1533 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Dec 2 11:48:48 UTC 2017
pkgbase = med-salome
pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64
- pkgver = 3.2.1
+ pkgver = 3.3.1
pkgrel = 1
url = http://www.code-aster.org/outils/med/
arch = i686
@@ -10,17 +8,17 @@ pkgbase = med-salome
license = LGPL
makedepends = gcc-fortran
makedepends = coreutils
- makedepends = swig2
- depends = hdf5-salome
+ makedepends = swig
+ depends = hdf5_18
depends = python2
optdepends = tk
- provides = med={pkgver}
+ provides = med=3.3.1
conflicts = med_fichier
conflicts = med
replaces = med_fichier
replaces = med
- source = http://files.salome-platform.org/Salome/other/med-3.2.1.tar.gz
- md5sums = 4965899bb578229ba27c9bc5293c651e
+ source = http://files.salome-platform.org/Salome/other/med-3.3.1.tar.gz
+ sha256sums = dd631ef813838bc7413ff0dd6461d7a0d725bcfababdf772ece67610a8d22588
pkgname = med-salome
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e04e1702933e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+med*.tar*
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index ae510c15bfd8..3c08adc66ad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Michele Mocciola <mickele>
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Michele Mocciola <mickele>
# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
# Contributor: Philippe Miron <tuxication@gmail.com>
# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
@@ -6,106 +7,46 @@
pkgname=med-salome
_pkgname=med
-pkgver=3.2.1
+pkgver=3.3.1
pkgrel=1
pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64"
url="http://www.code-aster.org/outils/med/"
license=('LGPL')
-depends=('hdf5-salome' 'python2')
-makedepends=('gcc-fortran' 'coreutils' 'swig2')
+depends=('hdf5_18' 'python2')
+makedepends=('gcc-fortran' 'coreutils' 'swig')
optdepends=('tk')
-provides=("med={pkgver}")
+provides=("med=$pkgver")
conflicts=("med_fichier" "med")
replaces=("med_fichier" "med")
-backup=()
arch=('i686' 'x86_64')
-source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz")
-
-md5sums=('4965899bb578229ba27c9bc5293c651e')
-
-_basesrcdir=${_pkgname}-${pkgver}_SRC
-# _installdir=/opt/${pkgname}
-_installdir=/usr
-_sharedir=${_installdir}/share/${pkgname}
+source=("http://files.salome-platform.org/Salome/other/$_pkgname-$pkgver.tar.gz")
+sha256sums=('dd631ef813838bc7413ff0dd6461d7a0d725bcfababdf772ece67610a8d22588')
prepare() {
- cd "${srcdir}"
-
-# uncomment if using cmake
-# if [ -d build ]; then
-# rm -rf build
-# fi
-
- cd ${srcdir}/${_basesrcdir}
+ mkdir -p build
-# uncomment if using cmake
-# sed -e "s|\${CMAKE_INSTALL_PREFIX}/\${PYFILELOC}/\${inputname}|\\\\\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${PYFILELOC}/\${inputname}|" \
-# -i config/cmake_files/medMacros.cmake
-
-# comment if using cmake
- sed -e "s|\$hdf5home/include|\$hdf5home/include/hdf5_18|" -i configure
- sed -e "s|\$hdf5home/lib|\$hdf5home/lib/hdf5_18|" -i configure
+ sed -i '/CODE/s,${CMAKE_INSTALL_PREFIX},\\$ENV{DESTDIR}&,' $_pkgname-${pkgver}_SRC/config/cmake_files/medMacros.cmake
+ sed -i '/CODE/s,${DESTDIR},\\$ENV{DESTDIR},' $_pkgname-${pkgver}_SRC/tools/mdump/CMakeLists.txt
}
build() {
- export FFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
- export FCFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
- export PYTHON="$(which python2)"
-
-# comment to compile mpi version (you need mpi version of hdf5)
- export CC="$(which gcc)"
- export CXX="$(which g++)"
- export FC="$(which gfortran)"
- export F77="$(which gfortran)"
-
-# uncomment to compile mpi version (you need mpi version of hdf5)
-# export MPICC="$(which mpicc)"
-# export MPICXX="$(which mpic++)"
-# export MPIFC="$(which mpif90)"
-# export MPIF77="$(which mpif77)"
-# export CC=$MPICC
-# export CXX=$MPICXX
-# export FC=$MPIFC
-# export F77=$MPIF77
-
-# comment if using cmake
- cd ${srcdir}/${_basesrcdir}
- ./configure --prefix=${_installdir} --with-med_int=int --datadir=${_sharedir} --with-swig=yes --with-hdf5=/usr
-
-# uncomment if using cmake
-# mkdir "${srcdir}/build"
-# cd "${srcdir}/build"
-# local python_version=2.7
-# local cmake_options=""
-# cmake_options+=" -DCMAKE_INSTALL_PREFIX=/usr"
-# cmake_options+=" -DCMAKE_BUILD_TYPE=Release"
-# cmake_options+=" -DMEDFILE_BUILD_SHARED_LIBS=ON"
-# cmake_options+=" -DMEDFILE_BUILD_STATIC_LIBS=OFF"
-# cmake_options+=" -DMEDFILE_BUILD_TESTS=OFF"
-# cmake_options+=" -DMEDFILE_INSTALL_DOC=ON"
-# cmake_options+=" -DMEDFILE_BUILD_PYTHON=ON"
-# cmake_options+=" -DPYTHON_INCLUDE_DIR=/usr/include/python${python_version}"
-# cmake_options+=" -DPYTHON_LIBRARY=/usr/lib/python${python_version}/config/libpython${python_version}.so"
-# # hdf5-1.8
-# cmake_options+=" -DHDF5_INCLUDE_DIRS:PATH=/usr/include/hdf5_18/"
-# cmake_options+=" -DHDF5_LIBRARY_DIRS:PATH=/usr/lib/hdf5_18/"
-# cmake_options+=" -DHDF5_C_COMPILER_EXECUTABLE:FILEPATH=/usr/bin/h5cc_18"
-# cmake_options+=" -DHDF5_C_LIBRARY_hdf5:FILEPATH=/usr/lib/hdf5_18/libhdf5.so"
-# cmake_options+=" -DHDF5_DIFF_EXECUTABLE:FILEPATH=/usr/bin/h5diff_18"
-# # swig2
-# cmake_options+=" -DSWIG_EXECUTABLE=/usr/bin/swig-2"
-# cmake ${cmake_options} \
-# ../${_pkgname}-${pkgver}
-
- make
+ cd build
+
+ cmake ../$_pkgname-${pkgver}_SRC \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DHDF5_NO_FIND_PACKAGE_CONFIG_FILE=ON \
+ -DHDF5_C_COMPILER_EXECUTABLE=/usr/bin/h5cc_18 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DMEDFILE_BUILD_PYTHON=ON \
+ -DMEDFILE_BUILD_TESTS=OFF
+
+ make
}
-
-package() {
-# uncomment if using cmake
-# cd "${srcdir}/build"
-# comment if using cmake
- cd ${srcdir}/${_basesrcdir}
+package() {
+ cd build
- make DESTDIR=${pkgdir} install
+ make DESTDIR="$pkgdir" install
}