summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2015-06-28 15:44:35 +0200
committerMichele Mocciola2015-06-28 15:44:35 +0200
commit995fa343fd7b3c29bf6368cb903c1397dc6356c1 (patch)
tree0b0747d4482b4c80ee9db87526b332c74a24c3c6
downloadaur-995fa343fd7b3c29bf6368cb903c1397dc6356c1.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD57
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b959fc2016bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = med-salome
+ pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64
+ pkgver = 3.0.7
+ pkgrel = 1
+ url = http://www.code-aster.org/outils/med/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-fortran
+ makedepends = coreutils
+ depends = hdf5
+ optdepends = tk
+ optdepends = python2
+ provides = med={pkgver}
+ conflicts = med_fichier
+ conflicts = med
+ replaces = med_fichier
+ replaces = med
+ source = http://files.salome-platform.org/Salome/other/med-3.0.7.tar.gz
+ md5sums = 8467068e8de471718b3f8d34c926d7be
+
+pkgname = med-salome
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..643817b08378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Michele Mocciola <mickele>
+# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
+# Contributor: Philippe Miron <tuxication@gmail.com>
+# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
+# Modified by: Martin Ortbauer <mortbauer@gmail.com>
+
+pkgname=med-salome
+_pkgname=med
+pkgver=3.0.7
+pkgrel=1
+pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64"
+url="http://www.code-aster.org/outils/med/"
+license=('LGPL')
+depends=('hdf5')
+makedepends=('gcc-fortran' 'coreutils')
+optdepends=('tk' 'python2')
+provides=("med={pkgver}")
+conflicts=("med_fichier" "med")
+replaces=("med_fichier" "med")
+backup=()
+arch=('i686' 'x86_64')
+source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('8467068e8de471718b3f8d34c926d7be')
+
+# _installdir=/opt/${pkgname}
+_installdir=/usr
+_sharedir=${_installdir}/share/${pkgname}
+
+build() {
+ export PYTHON="python2"
+
+ cd ${srcdir}/${_pkgname}-${pkgver}_SRC
+
+ ./configure --with-f90=gfortran --prefix=${_installdir} --with-med_int=int --datadir=${_sharedir}
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}_SRC
+
+ make DESTDIR=${pkgdir} install
+
+ ln -sf mdump3 ${pkgdir}/usr/bin/mdump
+ ln -sf xmdump3 ${pkgdir}/usr/bin/xmdump
+
+ # now move the testprograms to share, we don't want all the stuff in the bindir
+ for _FILE in usescases unittests testf testc testpy
+ do
+ mv ${pkgdir}${_installdir}/bin/${_FILE} ${pkgdir}${_sharedir}/
+ done
+
+ cd "${pkgdir}${_sharedir}/testpy"
+ for _FILE in `ls *.py`
+ do
+ sed -e "s|/usr/bin/env python|/usr/bin/env python2|" -i ${_FILE}
+ done
+}