summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-07-18 20:06:37 +0300
committerViktor Drobot2020-07-18 20:06:37 +0300
commit18c929afefdb3488cb7802a8c6c4691cf1fc5510 (patch)
tree9152165b42e0fd9dd6b60144ee3a459e1e4fe41f
downloadaur-18c929afefdb3488cb7802a8c6c4691cf1fc5510.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcb662b60c3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = medet-git
+ pkgdesc = A portable decoder for METEOR M weather satellite LRPT signal
+ pkgver = r18.8021339
+ pkgrel = 1
+ url = https://github.com/artlav/meteor_decoder
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = fpc
+ provides = medet
+ conflicts = medet
+ source = medet-git::git+https://github.com/artlav/meteor_decoder.git
+ sha256sums = SKIP
+
+pkgname = medet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad6fa450135a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=medet-git
+pkgver=r18.8021339
+pkgrel=1
+pkgdesc="A portable decoder for METEOR M weather satellite LRPT signal"
+arch=(i686 x86_64)
+license=('GPL3')
+url="https://github.com/artlav/meteor_decoder"
+makedepends=(git fpc)
+provides=(medet)
+conflicts=(medet)
+source=("$pkgname::git+https://github.com/artlav/meteor_decoder.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+
+ mkdir units
+ fpc -CX -XX -O3 -Mdelphi -FUunits -Fualib medet.dpr
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm755 medet "${pkgdir}/usr/bin/medet"
+}